Notifications
Clear all

[Closed] Moderators do not see wpForo menu in Dashboard

5 Posts
2 Users
0 Reactions
367 Views
Posts: 5
Topic starter
(@tony-robertsacer-org)
Active Member
Joined: 1 year ago

Hi guys,

We seem to be unable to display the wpForo menu in the WordPress Dashboard for users that don't have the wordpress administrator role.

I see in your documentation that this should be possible regardless of the wordpress administrator role (we are using the editor role).

Do you have any ideas? Thank you.

4 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @tony-robertsacer-org,

navigate to Dashboard > wpForo > Usergroups, edit the Moderator Usergroup and check the options with the Dashboard accesses.

Posts: 5
Topic starter
(@tony-robertsacer-org)
Active Member
Joined: 1 year ago

Hi Chris,

Thanks very much for your advice. We have the Moderator Usergroup configured with a number of Dashboard settings, but wht wpForo menu is not displaying in the dashboard for users with moderator.

Could I please confirm that there aren't any capabilities that need to be added to users? I gather from reading other posts that this isn't required.

Cheers, Tony

Posts: 5
Topic starter
(@tony-robertsacer-org)
Active Member
Joined: 1 year ago

Hi Chris, actually we have stumbled across the solution.

We had used .hide to remove .table.form-table.wpforo-profile-table from the user-edit.php screen (we have non administrators managing users in our environment), and this was preventing the change from the default registered usergroup to the moderator usergroup from applying, even though it looked fine in the members screen.

Might you have a suggestion to hide this section from the user-edit.php screen that does not break the plugin?

Cheers, Tony

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@tony-robertsacer-org,

Posted by: @tony-robertsacer-org

And this was preventing the change from the default registered usergroup to the moderator usergroup from applying, even though it looked fine in the members screen.

I don't follow this part, would be great if you could provide more details.