Notifications
Clear all

wpForo 1.x.x New Members Can't Post

4 Posts
2 Users
0 Likes
904 Views
becca800
Posts: 5
Topic starter
(@becca800)
Active Member
Joined: 3 years ago

Hello,

I have WP Foro integrated with Ultimate Member.

I have the four UM roles synched with the Forum Roles. The Roles are set to be able to create new topics.Β 

When a new user signs up, an account which is auto approved, they should be able to create new topics and reply, but they cannot. They can only do so if I pull up the member and "save" it again. No idea why this is happening.

http://gator4115.temp.domains/~mmpi/resources/forum/

Β 

Update: New users are being assigned to the default forum role even though synch is turned on.

Β 

3 Replies
Martin
Posts: 868
Moderator
(@martin)
Support Team
Joined: 6 years ago

It doesn't mean the synced is turned on or not. The default usergroup is designed to be attached to new registered users. Make sure your users default usergroup has appropriate permissions to create a topic and reply. They should have Standard Access.

Β 

And please forget about user Roles. wpForo users permissions are based on Usergroups and Forum Accesses. Please read this support topic to understand how wpForo permission system works: https://wpforo.com/community/how-to-and-troubleshooting-2/user-roles-and-permission-issues/#post-21032

Reply
becca800
Posts: 5
Topic starter
(@becca800)
Active Member
Joined: 3 years ago

Well, shoot. Thanks!

That worked.

I'm a moron... πŸ™‚

Reply
becca800
Posts: 5
Topic starter
(@becca800)
Active Member
Joined: 3 years ago

Nope. Nevermind. that didn't work at all.

I have set registered users to standard access. I have four user groups: teachers, schools, medical, and families.

Each role is set to synch with the forum user groups. the permissions are set so that only the family user group should have the ability to post in families. Every group is set correctly, but it doesn't work. Every user group can post in the other forums which they aren't supposed to be able to do. I've gone through the documentation. It just isn't working.

Attached see the four Forum usergroups synched with the UM roles. However, new signs up are being filtered straight to the subscribers/registered. And so the settings I've set for the forum user groups are completely useless.

Β 
When a new user signs up, they choose one of the four roles which are wp roles I created. After they sign up, their user profile in the back end shows the correct role. However, they are filtered into the subscriber role in wpforo. BUT - if I change their user role in the wp user admin area and save it, they then get removed from subscriber in wpforo and put into the new role and the correct wpforo usergroup.Β 
Reply