Notifications
Clear all

wpForo 1.x.x [Closed] New Topic & New Reply Email - Link Redirection Issue

28 Posts
3 Users
6 Reactions
3,014 Views
Posts: 22
Topic starter
(@gthellama)
Eminent Member
Joined: 4 years ago

Some of our members are complaining about the links on the 'New Topic' and 'New Reply' notification emails.

They said they are redirected to the main/index forum page instead of the reply or new topic whenever they click the link from the email. After that, they can't go into any topics in the forum. They are repeatedly redirected to the index forum page.

For example, 

when I create a topic, an email notification will be sent to the subscribers, right?

Then, from that email, there is a link that should redirect to the new topic posted.

When they click it, they are redirected to the main forum page instead of the new topic page. 

I noticed there is a strange parameter added on the link when they are redirected from the email and it does not go away unless I change the slug of that topic or the parent forum. Even if I remove the parameter, it goes back when I refresh the browser.

This is strange and it has been going on for so long on our site.

 Here is a screen recording of the issue.

https://screencast-o-matic.com/watch/crjhe8Vj10U

I found this thread as well that I think is similar to my concern

https://wordpress.org/support/topic/forosignin/

Can someone please help me with this? Thank you

27 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @gthellama,

I see /members/ path after the website domain:

https:// yourdomain.com/members/the-topic-path/

The forum base URL is wrong, it should not be /members/ it should be /forum/ or /community/ or something like that. The /members/ path will conflict with other plugins, so I recommend changing the forum base URL in the Dashboard > Forums > Settings > General Tab. Then go to Dashboard > Forums > Dashboard and click the [Delete All Caches] button.

With these changes, you should check the new topic URL's. The old one can not be fixed.

If the problem won't be fixed, please leave your Forum URL.

 

12 Replies
(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris Hello, thank you for your response. We intended to use /members/ for our forum so I don't think my team will allow me to change it. We also made sure to avoid using the same slug on other pages to avoid conflict with our forum.

Also, as you can see on the screen recording I attached, the URL issue does not affect all posts in the forum. Do you think this is just a member cache issue? Have you heard this concern before on other users? Thank you

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@gthellama 

Try to go by these steps`

  1. Make sure wpForo version is 1.9.9(Latest) if not, please update it
  2. If you have cache plugin, make sure to exclude wpForo pages from cache plugin settings (wpForo has built in cache system)
  3. Check does the logged-in user in the video has forum(topic) view access in the URL which is being redirected.
  4. Go to the redirected forum and check Forum permissions for Users after that go to Dashboard > Forums > Settings  > Forum Accesses Tab Edit the form accesses and make sure that the following checkboxes are checked`
    • Can view forum
    • Can view topic
    • Can view replies
    • Can view private topic

If all of these doesn't work, We will need administrator credentials in order for our developers to try to find a solution.

 

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris Thank you for this. This is a strange issue because not all of our member experiences it. 

  1. Make sure wpForo version is 1.9.9(Latest) if not, please update it **WPForo is in the latest version

  2. If you have cache plugin, make sure to exclude wpForo pages from cache plugin settings (wpForo has built in cache system) **I have disabled Varnish Cache on the forum pages
  3. Check does the logged-in user in the video has forum(topic) view access in the URL which is being redirected. **Yes all members have access to the forum(topic)
  4. Go to the redirected forum and check Forum permissions for Users after that go to Dashboard > Forums > Settings  > Forum Accesses Tab Edit the form accesses and make sure that the following checkboxes are checked`
    • Can view forum
    • Can view topic
    • Can view replies
    • Can view private topic

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@gthellama 

How I see by the screenshot you didn't check the forum accesses, you opened user groups.

 

Please give us administrator credentials that we could solve the issue, send it by this mail: info[at]gvectors.info

Once you send the email, please leave the subject here to help us find your mail

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris My apologies. Here's the standard access assigned to all members:

Also, here's a more in-depth recording of the redirect/link issues in the forum:

https://www.screencast.com/t/wUXOIx84Vf

Please give us administrator credentials that we could solve the issue, send it by this mail: info[at]gvectors.info

Once you send the email, please leave the subject here to help us find your mail

Got it. Thank you very much @chris.

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris Hello again. I have now sent the email with the admin login credentials to info@gvectors.info 🙂

The subject line is "HELP - New Topic & New Reply Email - Link Redirection Issue".

Thank you!

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

Hello @chris

Please give us administrator credentials that we could solve the issue, send it by this mail: info[at]gvectors.info

Unfortunately, I can't send the email to info@gvectors.info. 😔 Is the correct email info@gvectors.com? Just wanted to make sure before I share our credentials. Thank you.

 

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@gthellama,

Sorry my bad, the mail is info[at]gvectors.com

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris Thank you! Sending it again now.

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris Done 🙂

The subject line is "HELP - New Topic & New Reply Email - Link Redirection Issue".

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@gthellama,

We got the email, the developers team will work on the issue and let you know.

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris Thank you again!

Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

@gthellama,

We have checked everything on the website, tried every possible variants, deactivated wpForo however this is not wpForo core related issue.

Change Forum Page Slugs (URL Paths) "paged" to something similar, from Dashboard > Forums > Settings > General Tab

 

 

13 Replies
(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris 

Hello, may I ask what is the purpose of this?

Change Forum Page Slugs (URL Paths) "paged" to something similar, from Dashboard > Forums > Settings > General Tab

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@gthellama 

You have server side redirect with that name, so changing it will solve your problem.

That comes from your hosting, to get more information you need to contact your hosting providers.

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris I changed that slug but the issue still persists.

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@gthellama,

The solution we gave you worked on the website, where you gave us admin credentials, I guess you have done something wrong or there is difference between the real website and the other one, if you want, you can give us access to the real website to find out why our solution is not working.

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris The dev site I gave is a complete replica of the live site. Both sites are on the same server as well.

Here is the redirect issue we have encountered lately.

https://streamable.com/6zr8ij

RE the video above

I cleared the site and the plugin cache but the redirect is still incorrect. The redirect issue was resolved when I cleared my 'browser cache'.

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@gthellama,

We can't see the URL's in the video.

Give us an opportunity that we could test your website.

Are you using CDN, cloud servers like Cloudflare etc.

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris Hello, thank you for your reply. No, we are not using CDN on the site.

 

Here's a new issue with the URLs: https://streamable.com/b64hi6

 

Is it OK if I replicate our production site to our dev site and you can work on another test there?

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@gthellama,

So you found out how to solve the redirect issue?

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris No. We still haven't found a permanent solution to the issue.

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

@chris Hello again.

There is an issue specifically in the new topic I created a while ago "Wheel Arch Lip Repair" under Training>Wings:

https://streamable.com/xjygfv

I sent your access to our dev site via email: info@gvectors.com 🙂 

with the subject line "HELP - New Topic & New Reply Email - Link Redirection Issue Pt2"

Please let me know if there is anything you can suggest to help permanently resolve this issue?

Thank you so much!

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10523

@gthellama,

You've done some conflicting things.

1. I think you've set the forum base URL /members/.

If so, this is a big problem. The /members/ path might be used by other plugins. wpForo has its own /members/ path for wpForo members. I don't recommend you use the /members/ path as a base URL for forum in Forums > Settings > General Tab. The base URL should be /forum/, /community/ or something like that. Make sure you don't have other pages with the same base URL.

2. The forum page is closed for non-logged-in users. Try to click your forum URL as guest (make sure you're not logged in): https://www.learnpdronline.com/members/ You'll see that you're redirected to login page. This is your membership plugin input. The same thing goes on with any other forum pages. Make sure your forum is public accessible, otherwise all email URLs will be redirected to a login page.

3. The main problem maker is the Membership plugin. When you try to access any page under the /members/ path, it stops you, even if you're logged in. Something is wrong with this mambership plugin, it doesn't recognize sub-paths of the root protected page. Topic URLs are sub-paths of the main /members/ path like this:

https:// yourdomain.com / members/ blanding/ blanding-part-1/

So the membership plugin stop direct access to sub-paths. In other words. You should try to exclude forum from your membership plugin affection by changing the base path or by making forum public. Otherwise you'll have to contact the membership plugin developers and ask them to help you make their plugin compatible with wpForo.

(@gthellama)
Joined: 4 years ago

Eminent Member
Posts: 22

Thank you for your response @robert.

Re updating the forum base URL, it would be greatly appreciated if you can you kindly suggest a way to redirect the old base URL to the new one? Thank you!

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10523

@gthellama ,

I don't see what do you mean, saying old and new URL. I've already explained the issue and did some suggestions. You should either contact the membership plugin support or change the forum base URL to something that is not protected by membership plugin. For example, change the Base URL to /forum/ . The option is located in Dashboard > Forums > Settings > General Tab. Then delete all caches. Once it's changed, all your forum URLs will be changed automatically. We'll only need to change the Forum menu URL.