Notifications
Clear all

wpForo 1.x.x [Solved] Posts not visible unless logged in

5 Posts
2 Users
0 Reactions
755 Views
Posts: 50
Topic starter
(@upstartdm)
Trusted Member
Joined: 4 years ago

A user has reported that his posts are not visible unless he is logged in (in addition, post counts and last posts dates on the forum index page are also wrong if he's not logged in). I replicated the problem and have done some testing together with the user which suggests that the problem lies with a cache not being used or cleared correctly somewhere but I don't seem to be able to get any further - we use Cloudflare as a CDN with Automatic Platform Optimization enabled but despite disabling this, clicking Delete All Caches in wpForo and clearing browser caches the problem remains. Has anyone else seen this behaviour?

ย 

4 Replies
Sofy
Posts: 4565
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

@upstartdm,

There are the following reasons for the issue:

  1. The topics are private, those topics are visible only for the topic creator and high-level users, such as admins, moderators, etc.ย 
  2. Guests don't have permission to view the topics/posts. Please read this FAQ, it'll allow you to understand wpForo Usergroups and Forum Accesses.ย 
  3. Those topics/posts are anapproved. I'd suggest you read this article: https://gvectors.com/how-to-disable-topics-and-posts-moderation/
Posts: 50
Topic starter
(@upstartdm)
Trusted Member
Joined: 4 years ago

Thank you for the reply, I'm afraid none of those items are the case here but I've managed to track things down further and it looks like Cloudflare is the problem (as soon as development mode is disabled the problem disappears).

ย 

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4565

@upstartdm,

Thank you for letting us know.ย 

Posts: 50
Topic starter
(@upstartdm)
Trusted Member
Joined: 4 years ago

No problem, if anyone else encounters the same problem and comes across this topic I'm hopeful that creating a Cloudflare page rule which sets the cache level to "bypass" for wpForo forum urls will fix it (I'm testing that just now).

ย