Notifications
Clear all

wpForo 1.x.x [Solved] Posts won't display full width

7 Posts
4 Users
3 Likes
1,974 Views
Posts: 8
Topic starter
(@bucephalas)
Active Member
Joined: 5 years ago

I'm unable to get my posts to show correctly. They appear in just half of the screen as shown and the  "Leave a reply" text is in the wrong area.
Any ideas for a fix?

 

6 Replies
Posts: 8
Topic starter
(@bucephalas)
Active Member
Joined: 5 years ago

css looks ok on the content. I suspect the "leave a reply" box is causing the issue.

#wpforo #wpforo-wrap .wpforo-content{width:69%; float:left; padding:0px; box-sizing: border-box;}
#wpforo #wpforo-wrap .wpforo-content.wpfrt{padding-right: 20px;}
#wpforo #wpforo-wrap .wpforo-right-sidebar{width:28%; float:right; padding:0px 0px 0px 0px; box-sizing: border-box;}
#wpforo #wpforo-wrap [class*="content"]:after{clear: none;}

1 Reply
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10478
Posted by: Bucephalas

css looks ok on the content. I suspect the "leave a reply" box is causing the issue.

#wpforo #wpforo-wrap .wpforo-content{width:69%; float:left; padding:0px; box-sizing: border-box;}
#wpforo #wpforo-wrap .wpforo-content.wpfrt{padding-right: 20px;}
#wpforo #wpforo-wrap .wpforo-right-sidebar{width:28%; float:right; padding:0px 0px 0px 0px; box-sizing: border-box;}
#wpforo #wpforo-wrap [class*="content"]:after{clear: none;}

Hi @bucephalas,

If you have added any custom css to fix this problem please remove those. This is a conflict with your theme custom CSS.

To fix this conflict please navigate to Dashboard > Forums > Settings > Styles admin page, put this CSS code in Custom CSS Code Textarea, save it, delete all caches, navigate to forum front-end and press Ctrl+F5 to deep refresh the browser.

#wpforo #wpforo-wrap .wpforo-main .post-wrap {
   width: auto;
    height: auto;
    float: none;
    position: inherit;
}
Posts: 8
Topic starter
(@bucephalas)
Active Member
Joined: 5 years ago

Superb!
Many thanks on the reply and thanks for a great a great forum!

Posts: 8
(@ebonynsweet)
Active Member
Joined: 2 years ago

I'm having a similar issue, but with the iPad mobile version of my website ( https://ebonynsweet.com/forums ). It does work properly on the desktop version, and I used the Developer Tools for chrome to see what it looks like in mobile view and it looks correct. But somehow, the width is still not sizing up on the ipad. This is the CSS code that I used:

#wpforo #wpforo-wrap {
font-size: 15px; width: 111%; padding:0px 15px; margin:0px;
}

-----

and I also added the "Fix" as mentioned in this thread. But it didn't work for me.

-----

 

Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @ebonynsweet,

I have checked your forum and saw that the forum length is equal to your website length(website menu length), the forum length will be fixed if you fix the website length(website menu length).

1 Reply
(@ebonynsweet)
Joined: 2 years ago

Active Member
Posts: 8

@chris greetings, I corrected the issue by removing the sidebar on the same page that I used to insert the short-code and install the forum.

For future references, in case anyone else has this problem. After using the CSS Code, you should remove the sidebar to your theme by utilizing another Plug-In. A few plugins can remove it for you; click plugins>add plugins and search “remove the sidebar.” Then after you remove your theme’s sidebar, replace it with wpforo sidebars by using the theme’s editor. Other plugins will allow you to add and remove widgets, too, if the editor that came with your theme can't do it.

After I took those steps, it looked great on the iPad.