Notifications
Clear all

wpForo 1.x.x [Solved] Problems with profile links

13 Posts
3 Users
0 Likes
992 Views
Alex19
Posts: 8
Topic starter
(@alex19)
Active Member
Joined: 2 years ago

Hi;

I'm building a forum with your plugin on a Buddypress based community. The problem is that the wpforo links to profile doesn't work and they redirect to a 404 page. As an example, when you hover over the the link to the forum tab on my profile, the url appears like this:

https://www.daggas.life/comunidad/alex-bosch//community/

When the real url is this one : https://www.daggas.life/comunidad/alex-bosch/foro/

I already cleared all the caches and it didn't change at all.

How can I solve that? 

 

Thank you in advance.

12 Replies
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

@alex19,

We've just checked your forum it works fine. Please watch the video below:

https://www.screencast.com/t/hAdxIEvfdyP

Alex19
Posts: 8
Topic starter
(@alex19)
Active Member
Joined: 2 years ago

Hi;

 

Thank you, but the problem is not with this link, neither with all the other ones that redirects to the front page of the profile. The problem is with the links that redirect to the forum tab on the profile (the ones below the author comment photo and the ones on the forum menu when you're logged in). On the photo I attach, you can see the on the bottom left link to the page it sends you when you click on the forum icon.

It happens exactly the same with the subscriptions icon and with the menu tabs that send you to the same two pages when you are logged in.

Please, help me. 

Thank you.

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@alex19,

If you have some cache plugins please exclude wpForo page from the plugin settings. More info here: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

Then navigate to Dashboard > Forums > Dashboard admin page, one by one click on the "Delete User Cache" then "Delete All Caches" buttons. 

Also, let us know the versions of the BuddyPress and wpForo you're using. 

Alex19
Posts: 8
Topic starter
(@alex19)
Active Member
Joined: 2 years ago

Hi Sofy;

 

Thank you for your answer. I'm using the last version of Buddypress and wpForo.

I already disabled the url of wpForo page on my cache plugins (I use Autoptimize and w3 Total Cache, I can't see your recommended configuration of these two plugins) and cleared the user cache and all caches from wpForo...

Nothing changed

Alex19
Posts: 8
Topic starter
(@alex19)
Active Member
Joined: 2 years ago

Can you please help me with this? Thank you

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@alex19,

Please try to deactivate the cache plugins and check again. 

Page 1 / 2