Notifications
Clear all

wpForo 1.x.x [Closed] Redirect to Admin php file after log in

25 Posts
3 Users
2 Likes
1,788 Views
dimalifragis
Posts: 2569
(@dimalifragis)
Famed Member
Joined: 4 years ago

Fix your page issues:

 

4 Replies
OMTesla
(@omtesla)
Joined: 8 years ago

Active Member
Posts: 217

@dimalifragis 

When I do inspect element it not show anything in console like your image.

Even if it is there, not sure how to fix that error.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2569
Posted by: @omtesla

@dimalifragis 

When I do inspect element it not show anything in console like your image.

Even if it is there, not sure how to fix that error.

Not sure what you mean by "even IF it is there". It is there.

How to fix it? probably some conflict with other plugins, this is for you to debug.

 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10503

@omtesla,

Yes, the errors exist, and they are result of your cache plugin minifier and JS DEFER loading option. You can see errors on almost all pages, not only on the forum page.

BTW, as far as I see the registration and login pages are not wpForo reg and login pages, so the redirect issue doesn't have any relation to wpForo plugin. The issue cannot be fixed from wpForo side. You should fix the redirection problem with the membership plugin support.

In any case, please navigate to Dashboard > Forums > Settings > Members Tab and make sure all fields of this option are empty:

OMTesla
(@omtesla)
Joined: 8 years ago

Active Member
Posts: 217

@robert 

This are always empty, I know about wpForo many settings.
I use s2member registration form and wpForo login form.

Not sure why you say that both reg/login is not from wpForo?!

dimalifragis
Posts: 2569
(@dimalifragis)
Famed Member
Joined: 4 years ago

Here could be the cause of the issue, Optimizers:

 

<script defer src=' https://omtesla.com/wp-content/cache/wpo-minify/1652045967/assets/wpo-minify-footer-14381af0.min.js '

OMTesla
Posts: 217
Topic starter
(@omtesla)
Active Member
Joined: 8 years ago

Everything was working together with cache plugin, I was getting this issue even before recent updates to s2member and wordpress itself, did not have time to write a topic to ask.

1 Reply
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2569
Posted by: @omtesla

Everything was working together with cache plugin, I was getting this issue even before recent updates to s2member and wordpress itself, did not have time to write a topic to ask.

It was not. NO caching works with wpForo. None. At the best, you were serving OLD pages to the visitors.

 

OMTesla
Posts: 217
Topic starter
(@omtesla)
Active Member
Joined: 8 years ago

This is what I observed in the link, but not sure from where it adds that redirect.

 

2 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10503

@omtesla,

This is a wrong URL. Please change it to this:

 https://omtesla.com/forums/?foro=signin&redirect_to=https%3A%2F%2Fomtesla.com%2Fforums%2F 
OMTesla
(@omtesla)
Joined: 8 years ago

Active Member
Posts: 217

@robert 

That link is generated automatically by s2member when I select in settings to let s2member to customize the login/registration page instead of WP, somehow all 3 (WP, s2member, wpForo) are mixing together and output that link.

OMTesla
Posts: 217
Topic starter
(@omtesla)
Active Member
Joined: 8 years ago

Hello Robert

Other thing, the /wp-login.php page is active even with enabled feature, Replace WP login Page url to wpForo url.

I think it must disable this login method with that feature or not?

6 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10503

@omtesla,

No, wp-login.php is a file, it's not a path, so wpForo cannot disable it. You can use other solution to disable it: https://wordpress.org/plugins/block-wp-login/

OMTesla
(@omtesla)
Joined: 8 years ago

Active Member
Posts: 217

@robert 

I have disabled the cache plugin and testing, because I feel you both were right.

If it works I wonder what minify file must be excluded from minify or cache, but I feel it is minify issue, cause I minify everything in the settings.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2569
Posted by: @omtesla

@robert 

I have disabled the cache plugin and testing, because I feel you both were right.

If it works I wonder what minify file must be excluded from minify or cache, but I feel it is minify issue, cause I minify everything in the settings.

For caching, use some simple and tested plugin, like Fastest cache or WP Super Cache, EXCLUDING the [ wpforo ] page.

About optimizations (minify etc etc) use some tested plugin, like Autoptimize. BUT keep in mind in 2022 optimizations are a waste of time and speed. Not needed in http/2.

 

OMTesla
(@omtesla)
Joined: 8 years ago

Active Member
Posts: 217

@dimalifragis 

Surprise, it's not the cache plugin, today I login and same thing, the WP Optimize is one of the best from all tested plugins.

Anyway it is still disabled so not sure what is the issue, might be some s2member incompatibility.

As I mentioned before the Forum page was excluded from cache all the time, because I know Robert said that wpForo does not need to be cached, it has it's own cache.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2569

@omtesla Dude, i don't know. You do all kind of strange things in your site, i can't (now) use F12 to check it out.

WP Optimize is NOT the best plugin for that, by all means.

As for cache, it is NOT that "wpForo doesn't NEED caching". Caching wpForo with traditional plugins (with static html pages), creates all kind of problems, optimizing also.

Anyways, good luck.

OMTesla
(@omtesla)
Joined: 8 years ago

Active Member
Posts: 217

@dimalifragis 

You will tell me what is good for my website, I know my website as my body and I know what is best for him.

Those cache plugins you mentioned are like harmful vaccines, the WP Optimize is natural medicine for my website.

I know you want to be helpful and receive allot of likes, but believe me I was doing same thing, then I left, there are better things to do. Beside there are developers who know very good how to support us. 😉 

P.s. yes I know how to push the buttons.

Page 2 / 2