Notifications
Clear all

wpForo 1.x.x [Closed] Regular pages of my site open as 404 pages of the Forum

16 Posts
4 Users
1 Likes
1,770 Views
envi
Posts: 29
 envi
Topic starter
(@envi)
Eminent Member
Joined: 4 years ago

Hi,

I've changed the permalink structure to mysite.com/sample-post/ & I generate the redirects.
But now 4 of my pages are open as 404 Page of my Forum.

topzalozi.com/forum-prognozi-visoka-uspevaemost/
topzalozi.com/foruma-totnam-titlata/
topzalozi.com/foruma-pobeda-barselona-gola/
topzalozi.com/foruma-real-hetafe/

I note that all 4 pages start with the word "forum". And this is the word that I use as a slug for my forum ( topzalozi.com/forum/ ).
How can I fix this problem?

Topic Tags
15 Replies
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @envi,

 I generate the redirects.

How have you generated the redirection? If you turn this back is it worked?

envi
Posts: 29
 envi
Topic starter
(@envi)
Eminent Member
Joined: 4 years ago

I created the redirects with this tool: https://yoast.com/research/permalink-helper.php
I followed these instructions: https://yoast.com/change-wordpress-permalink-structure/

My old permalink structure was: /%year%/%monthnum%/%postname%/
My new permalink structure is: /%postname%/

The generated code for me is: RedirectMatch 301 ^/([0-9]{4})/([0-9]{2})/(?!page/)(.+)$ https://topzalozi.com/$3

I placed this code in my .htaccess file.

Everything works properly now except just these 4 pages which starts with the slug "forum". Now I can't read them. These pages are opening as 404 Page in the Forum.

1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@envi

The redirection rule is not perfect, and this issue cannot be fixed from wpForo side, this is not wpForo issue. I recommend change the wpForo base URL from /forum/ to /community/ or to some unique name. Delete all caches and then use other browsers or private sessions, because browsers caches redirections very hard. Even the redirection doesn't exists browsers still do that.

 

P.S. I don't recommend use solutions for redirection. WordPress has its own permalink management options in Settings > Permalink admin page.

envi
Posts: 29
 envi
Topic starter
(@envi)
Eminent Member
Joined: 4 years ago

Yes, I use the WordPress permalink management options in Settings > Permalink admin page. But I have to generate redirections for the old posts.

And now I realize that the problem has not come from the redirects. I've just published a new post with the slug "forum" in the beginning: https://topzalozi.com/forumche/ . This post also is opening as a 404 Page in the Forum. So every post with the word "forum" in the begging of the URL is opening as 404 Page in the Forum now. What cause this?

1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@envi

This is not wpForo problem for sure, and you should search problems in other plugins or in your configurations. Just disable all plugins, delete all caches and follow to the instruction using browsers to test. We at wpForo support cannot help you fix this issue, because wpForo core functions are not the problem-makers.

envi
Posts: 29
 envi
Topic starter
(@envi)
Eminent Member
Joined: 4 years ago

Hi Robert,

When I disable wpForo, this problem disappears. And all 4 posts are opening properly.

2 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@envi

Ok, then follow to my post above and change the base URL, then delete all caches as I described: https://wpforo.com/community/how-to-and-troubleshooting-2/regular-pages-of-my-site-open-as-404-pages-of-the-forum/#post-28815

 

This is not wpForo issue, this is a conflict with wpForo.

envi
 envi
(@envi)
Joined: 4 years ago

Eminent Member
Posts: 29

@robert

If I change the base URL, I think this will generate a lot of 404 pages on my website. And maybe this is not a good solution.

So I disable all plugins, delete all caches and so on. Nothing. This problem disappears only when I disable wpForo.

I have recreated this problem on 2 test sites too with just one active plugin on them - WPforo. The same situation.

WP Setting > Permalinks: Post name.
WPforo slug: forum
Regular Post slug: forum1

And the post is not open. Instead is open the 404 page of the forum.

Test site 1:
Forum: http://fragile-iguana.w5.poopy.life/forum/
Regular Post: http://fragile-iguana.w5.poopy.life/forum1/

Test site 2 (access code: 000):
Forum: http://plugin-tests.qsandbox.com/forum/
Regular Post: http://plugin-tests.qsandbox.com/forum1/

Please, help me with this!

Page 1 / 2