Notifications
Clear all

wpForo 1.x.x [Solved] Remove blog theme's sidebar

22 Posts
8 Users
6 Likes
10.4 K Views
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi Mondesensuel,

This comes from your WordPress Theme page design and has no relation to wpForo.

Try this CSS code, navigate to Dashboard > Forums > Settings > Styles admin page, put it in Custom CSS Code textarea. 

.vl-container {
width: auto !important;
}
Fredrikwordpress
Posts: 14
(@fredrikwordpress)
Active Member
Joined: 4 years ago

I  was just wondering whether it was possible to get the forum to be wider than this? 

https://www.nyurban.no/forum/?preview=true#

I would ideally have wanted it to be as wide as possible, but I can't figure out how do edit it. 

1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912
Posted by: Fredrikwordpress

I  was just wondering whether it was possible to get the forum to be wider than this? 

https://www.nyurban.no/forum/?preview=true#

I would ideally have wanted it to be as wide as possible, but I can't figure out how do edit it. 

Hi @fredrikwordpress,

This is your theme width and it wraps wpForo forum area in 70% width of #primary div. You can fix this using a custom CSS. Please put this CSS code in Dashboard > Forums > Settings > Styles > Custom CSS Code textarea. Save it, delete all caches, navigate to forum front-end and press Ctrl+F5 to load css code changes.

body.wpforo #primary {
      float: none;
      width: 100%;
}
Fredrikwordpress
Posts: 14
(@fredrikwordpress)
Active Member
Joined: 4 years ago

Hey. Thanks. That worked great, but I think it ended up being slightly to the right of the other pages although it could be my imagination. Is there any way  to move the whole forum to the left? 

https://www.nyurban.no/forum/#

Or what do you think? Does it appear to be located too far to the right? 

 

Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @fredrikwordpress,

You've added CSS with a wrong value. You've written:

width: 110%;

instead of

width: 100%;

Then add the following CSS:

.inner-wrap {
max-width: 94% !important;
}

Delete all caches and check again.

Fredrikwordpress
Posts: 14
(@fredrikwordpress)
Active Member
Joined: 4 years ago

Thanks. I tried that code, but then it messed up the rest of the webpage. How do I make it so that it only impact the forum pages? 🙂

Page 3 / 4