Notifications
Clear all

wpForo 1.x.x [Closed] Unfortunately it is not working correctly

6 Posts
3 Users
1 Likes
1,982 Views
Posts: 7
Topic starter
(@martymedia)
Active Member
Joined: 6 years ago

Hi, I have just migrated from phpbb to wpforo and I am testing now. I startet a topic and our moderators replied. They are 6 replies in this topic. If I am not logged in, I can see only the first two. The original post and the first reply. If I log in, I can see every post. A visitor need to see every post if he is not logged in. Where is the problem?

A Moderator reported, that if he logs in and click through the forum, the logout button changes back to login and back to logout all the time.

5 Replies
Robert
Posts: 10503
Admin
(@robert)
Support Team
Joined: 8 years ago

This is only migration and wrong permission configuration issue. wpForo works fine it doesn't have such problems. The migrated data are not complete and users have incorrect permissions. Here are the steps to check:

1. Disable the HTML cache in Dashboard > Forums > Settings > Features admin page, then navigate to Dashboard > Forums > Dashboard admin page and click on Deleting and Synchronizing buttons.

2. Edit all forums and make sure the Registered and Moderator Usergroups are attached to correct Forum Accesses. Check the forum Accesses and make sure "Can view forum" is enabled for them.

Forum Accesses doc: https://wpforo.com/docs/root/wpforo-settings/forum-accesses/

3. Create new user or moderator and check it.

Posts: 7
Topic starter
(@martymedia)
Active Member
Joined: 6 years ago

Thanks for your reply. I will check this.

Posts: 7
Topic starter
(@martymedia)
Active Member
Joined: 6 years ago

I tried but nothing worked. I figured out what the problem was. It was not the forum nor my migration. It was the Plugin "WP Fastest Cache" which was not working correctly with wpforo. I could not see every post, font-awesome doesn't work correctly and so on. As soon I deactivated "WP Fastest Cache", everything worked fine in wpforo.

Thanks for your help.

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago
Posted by: MartyMedia

I tried but nothing worked. I figured out what the problem was. It was not the forum nor my migration. It was the Plugin "WP Fastest Cache" which was not working correctly with wpforo. I could not see every post, font-awesome doesn't work correctly and so on. As soon I deactivated "WP Fastest Cache", everything worked fine in wpforo.

Thanks for your help.

Just EXCLUDE the base page of wpforo from Fastest Cache.

Page 1 / 2