Notifications
Clear all

wpForo 1.x.x Want to do manual registration of forum members

14 Posts
4 Users
1 Likes
3,015 Views
Posts: 2
Topic starter
(@johnlombard)
New Member
Joined: 5 years ago

I have set up an online course on Teachable.com.ย  I want to have a forum for students to discuss the course, but Teachable is not compatible with the WPForo membership system.

I don't want open registration, as only people who've paid for my course should have access. So I want to A) turn off the option for people to register themselves, and B) be able to add members myself, using the username and email info from their course signup.

Please let me know how I can do this.

13 Replies
Robert
Posts: 10154
Admin
(@robert)
Support Team
Joined: 7 years ago

You can register new users in Dashboard > Users > New User admin page.

You can disable forum registration in Dashboard > Forums > Settings > Features admin page. Just set "No"ย  the "Enable User Registration" option.

Reply
2 Replies
(@johnlombard)
Joined: 5 years ago

New Member
Posts: 2

Great, simple answer, works perfectly ๐Ÿ™‚

Reply
(@paularenson)
Joined: 5 years ago

Eminent Member
Posts: 13

There is one problem. They get taken to the general login page after resetting their PW. ย Then if they click login, they get taken to the WordPress Profile, which does not show the page itself.ย 

ย 

https://gale-sig.org/community/?wpforo=signin

Is there a way to force them to go to the form page to login so they don't get lost in the Word Press profile?

Reply
Sofy
Posts: 4053
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi paularenson,

you need to enable theย "Replace Reset Password Page URL to Forum Reset Password Page URL" option.ย 

ย 

Reply
Posts: 13
(@paularenson)
Eminent Member
Joined: 5 years ago

Thank you Sofy. That worked, combined with Theme my login extension to force moderation so I do not get robot or other malicious signups.

ย 

Only one problem. I lost my gale-sig.org/wp-admin login. I have login via the forum and then find the dashboard. ย Wonder what happened?

Reply
Robert
Posts: 10154
Admin
(@robert)
Support Team
Joined: 7 years ago

Make sure the "Replace Login Page URL to Forum Login Page URL" option is set "NO" in Dashboard > Forums > Settings > Features admin page:

Reply
Page 1 / 3