Notifications
Clear all

wpForo 1.x.x [Solved] Unsubscribe doesn't work

10 Posts
4 Users
3 Reactions
957 Views
Posts: 76
Topic starter
(@jeanne)
Estimable Member
Joined: 7 years ago

@Robert, I'm getting the same complaint.  The readers says she has unsubscribed from all topics but still gets email notifications.  I have set up my forum so that people are automatically notified of new posts and have to opt out if they don't want to be notified. There is an unsubscribe button next to every post they read.  This reader says she still gets notified. 

 

9 Replies
Alvina
Posts: 1867
Moderator
(@alvina)
Member
Joined: 5 years ago

1. Please navigate to the Dashboard > Forums > Settings > Emails admin page and make sure the email of the certain user there isn't filled in the "Forum Admins email addresses" list.

2. Please ask the user to navigate to his/her Subscription page, and make sure the "Subscribe to all new topics and posts" is unchecked. And he/she is unsubscribed for the current topic. It'd be better if the user could provide some screenshots of that page to make sure.

 unsubscribe.png

3. And finally please make sure that the same user doesn't register to the forum with two different email addresses. So he/she has subscribed to the current topic with both mails, then unsubscribed only from one account, thus he/she gets a notification to another email address.

Posts: 76
Topic starter
(@jeanne)
Estimable Member
Joined: 7 years ago

Thank you, @Alvina! The user wasn't listed in the administrator emails, but I did clear the user cache and all the caches and did site maintenance that is provided on the first page of the dashboard, and one of the two people who had reported having the problem wrote back that the problem disappeared. The other one did not respond so perhaps no news is good news! 

There was a problem when I did site maintenance however that keeps happening: The last check box <Sync User Profiles> doesn't work. The color of the page turns light blue and the application keeps trying to work but never stops trying. I let it work for about fifteen minutes before closing out the page. 

5 Replies
(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602
Posted by: @jeanne

There was a problem when I did site maintenance however that keeps happening: The last check box <Sync User Profiles> doesn't work. The color of the page turns light blue and the application keeps trying to work but never stops trying. I let it work for about fifteen minutes before closing out the page. 

Probably crashed. Do that again, after pressing F12 and check the console for errors.

Also maybe some other errors happens, enable debug to a LOG and check that out.

(@jeanne)
Joined: 7 years ago

Estimable Member
Posts: 76

@anonymous20, Thank you. I don't know how to enable debug to a LOG.

Sorry I'm not a developer and maybe I have no business running a forum without being a developer but wpforo has been so great that I've managed so far.  

 

 

(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602

@jeanne

Not sure what you say, no developer also myself.

Plenty of information when google is searched.

https://www.wpsecurityauditlog.com/wordpress-admin/enabling-wordpress-debug/

 

(@jeanne)
Joined: 7 years ago

Estimable Member
Posts: 76

@anonymous20. Duly noted!  You sound like an expert developer!  Thanks will do.  I am encouraged. 

 

(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602
Posted by: @jeanne

@anonymous20. Duly noted!  You sound like an expert developer!  Thanks will do.  I am encouraged. 

 

No i'm just an experienced web master, doing support job for php scripts in the hosting industry, while having fun with my sites also.

 

Robert
Posts: 10525
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @jeanne,

I think your users are talking about the email notification sent on @nickname mentioning. So just stop searching for bugs, all is correct. It doesn't mean you're subscribed or not, if your nickname is mentioned you'll get a notification. We'll add a button in Subscription Tab of all user profiles to let them disable User Mentioning Notifications.

Also, you have an option to disable this notification for all users in Dashboard > Forums > Settings > Emails Tab. Just find the "Enable Email Notification" option in User mentioning section and disable it:

 

Posts: 76
Topic starter
(@jeanne)
Estimable Member
Joined: 7 years ago

@Robert Thank you for helping with this. I made a test account and unsubscribed from various topics and have not received notifications.  So it is working.

I also checked the account of the user who was complaining repeatedly about too many email notifications -- even after I did site maintenance which stopped other users' complaints -- and discovered that in spite of her maintaining that she had been unsubscribing from topics and still receiving notifications, she actually was subscribed to 30 topics!  So lesson learned on my part to always check for myself when people make claims.  

As for people wanting to opt out of @nickname mentioning, that will be good to get that option in the future, but it is not a source of complaints from my users. 

Thank you all for your help.