Notifications
Clear all

wpForo 1.x.x [Closed] Issues with the Flatsome Theme

13 Posts
5 Users
0 Likes
3,867 Views
Posts: 6
Topic starter
(@manuel-b3)
Active Member
Joined: 5 years ago

Hello,

we have issues with the UX Builder from the Flatsome Theme in combination with wpForo.

As long we have activated wpForo, the UX Builder is not working (Please see the screenshot). After consultation with Flatsome, they told us we should switch to another software. But this is not our prefered solution.

Best regards,

Manuel

12 Replies
Alvina
Posts: 1869
Moderator
(@alvina)
Member
Joined: 5 years ago

Hi @manuel-b3,

The wpForo developers checked your website and saw, that the issue doesn't have any relation with the wpForo, so it can't be solved by the wpForo side. There is a lot of JS error that's the reason the website doesn't work properly, even if the wpForo is deactivated.

There are two loopBack problems caused by the current active theme or the other plugins. See the screenshot below:

 loopback_problem.png

Also, there are lots of JS errors caused by the active theme, even if the wpForo is deactivated.

Alvina
Posts: 1869
Moderator
(@alvina)
Member
Joined: 5 years ago

@manuel-b3,

It will be better if you deactivate the plugin one by one and check after each deactivation to find the problem maker one.

Posts: 6
Topic starter
(@manuel-b3)
Active Member
Joined: 5 years ago

Thansk for your help.

We allready checked all plugins. Even if we deactivate all plugins exept Wpforo, the UX Builder doensn't work. We contacted flatsome for help.

3 Replies
(@dartrax)
Joined: 4 years ago

New Member
Posts: 4

Hi @manuel-b3,

what was the solution? I'm facing exactly the same issue. Unfortunately, this topic and another related one ( https://wpforo.com/community/wpforo-integration/incompatible-with-flatsome-themes-uxbuilder/ ) do not provide a solution yet.

Thank you!

Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1869

@dartrax, @manuel-b3,

Since the wpForo  1.7.3 added a new hook to stop conflicts with Page builder plugins, such as Flatsome theme page builder. In this case, you should enable the hook with this code: 

add_filter('on_wpforo_load_remove_the_content_all_filters', '__return_true');

You just need to update the wpForo to the latest version and check again.

More info here: https://wpforo.com/community/wpforo-announcements/wpforo-1-7-3-is-released/

(@dartrax)
Joined: 4 years ago

New Member
Posts: 4

@alvina,

thank you for your answer. That are the steps I've tried:

  1. Deactivate all Plugins except WPForo,
  2. Insert this line in my child's theme functions.php, 
  3. navigate to Dashboard > Forums > Dashboard and click the [Delete All Caches],
  4. disable wpForo Output Buffer in Dashboard > Forums > Settings > Features Tab,
  5. try to start UX Builder in a new inkognito window

Unfortunately, the problem remains the same.

As soon as I deactive the only remaining plugin "WPForo", the UX-Builder instantly works.

What can I do now?

Posts: 986
Moderator
(@martin)
Support Team
Joined: 8 years ago

@dartrax,

Please let me know if you read the reply by Alvina above. Have you added that code?

As @alvina said you should put the hook code to try fix it. Make sure you use the latest wpForo version. Enable the wpForo Output Buffer back and put that code in your functions.php file as explained above:

add_filter('on_wpforo_load_remove_the_content_all_filters', '__return_true');
4 Replies
(@dartrax)
Joined: 4 years ago

New Member
Posts: 4

@martin,

of course, that was a direct reply to @alvina s reply.

  • I use WPForo Version 1.7.4 and Flatsome version 3.11.3
  • The code line is in flatsome child theme functions.php
  • Output Buffer is enabled

Unfortunately, the problem remains the same.

As soon as I deactive the only remaining plugin "WPForo", the UX-Builder instantly works.

What can I do now?

Alvina
Moderator
(@alvina)
Joined: 5 years ago

Member
Posts: 1869

@dartrax

Sorry for the late response.

Please leave your forum URL to allow us to check it.

(@dartrax)
Joined: 4 years ago

New Member
Posts: 4

@alvina,

I've been in contact with support center by mail, and, after accusing the servers memory limit to be the cause (I was told that 512mb is not enough for wpforo and ux builder together, but 1024mb did not solve the problem, so that was not true), they finally admitted having a bug in wpforo.

It is fixed on my homepage now, and should be for all with the next wpforo plugin update.

(@manuel-b3)
Joined: 5 years ago

Active Member
Posts: 6

@dartrax Ok. We integrated the code, but it still does not work. So we are waiting for the update.

Page 1 / 2