Notifications
Clear all

wpForo 1.x.x URL Adress Identifier

3 Posts
2 Users
0 Likes
242 Views
Alsansan
Posts: 9
Topic starter
(@alsansan)
Active Member
Joined: 2 years ago

I have "user url structure" setting in /USER_ID/ because i want to hide emails of social login users of my site. The issue is that in user account settings the field "URL Address Identifier" displays the user ID, and if someone want to modify his account the first time, can't save settings unless modifying the number displayed in url adress identifier. That's little user friendly and I want to fix it. Some help please?

Thanks!

2 Replies
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @mocs,

The issue is that in user account settings the field "URL Address Identifier" displays the user ID

Depending on the option you check in the "Member URL Structure" setting, you will see / Nicename / or / UserID / in the member Profile URL. More info here: https://wpforo.com/docs/root/wpforo-settings/members-settings/#members-url

 and if someone want to modify his account the first time, can't save settings unless modifying the number displayed in url adress identifier.

Could you please record a video with the issue and leave it here.

Reply
Alsansan
Posts: 9
Topic starter
(@alsansan)
Active Member
Joined: 2 years ago

Ok, I attached the video.

Observe that I can't save because alfanumeric alias are not allowed. If I change manually the nicename, when I logout and login it shows again the ID.

So... make sense that edit profile form should display the nicename even if "userID member url structure is turned on". that's at least what i want to change.

Thanks!

Reply
Share: