Notifications
Clear all

wpForo 1.x.x [Solved] User profile redirects to 404

4 Posts
1 Users
1 Likes
650 Views
Joonas Kolostov
Posts: 5
Topic starter
(@stopz)
Active Member
Joined: 2 years ago

I have just installed wpForo about 3 days ago and some of my users (at random) experience page not found (404) on their account pages /profile, /account & /activity.

I checked mysql database to see if there's anything odd with their accounts but no, nothing that stands out to me.

My website in question is: äri.ee and the users that reported this anomaly are:

  • ari-ee
  • kristiineautorent

you can find them under Members tab, which is "Liikmed" in the top menu.

I also checked the code for wpForo plugin and could not find anything on my part i have redirects only for wp-login.php and wp-admin which i suppose do not interact with with wpForo's member views?

My htaccess file is:

<IfModule mod_deflate.c>
    <FilesMatch "\\.(js|css|html|htm|php|xml)$">
        SetOutputFilter DEFLATE
    </FilesMatch>
</IfModule>
FileETag MTime Size

<IfModule expires_module>
    ExpiresActive on
    ExpiresDefault "access plus 1 week"
</IfModule>

RewriteEngine On

# Redirects.
RewriteCond %{REQUEST_URI} ^/wp-login.php
RewriteCond %{QUERY_STRING} !(?:^|&)action=[^&]+ [NC]
RewriteRule (.*) /wp-admin/login [L,R,QSD]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule .+ - [L]

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !\.(jpg|png|gif|css|js|ttf|txt|html|htm|json|ico)$

RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ ./wp-content/themes/%{HTTP_HOST}/$1

# BEGIN WordPress
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]
# END WordPress

Topic Tags
3 Replies
Joonas Kolostov
Posts: 5
Topic starter
(@stopz)
Active Member
Joined: 2 years ago

Also i need to mention: Yes i have tried deleting all cache in wpForo, yes i have tried wordpress default .htaccess, yes i have tried deactivating and activating wpForo and finally, yes- i have tried unplugging all of my own custom code and plugins.

List of plugins that run aside wpForo:

Akismet Anti-Spam
Cookies and Content Security Policy
Dashboard Cleaner
Loco Translate
Pro Sites
Simple Custom CSS
Simple Local Avatars
Site Kit by Google
WordPress MU Domain Mapping
WP Favicon Remover

Hope this helps :/

Joonas Kolostov
Posts: 5
Topic starter
(@stopz)
Active Member
Joined: 2 years ago

Update: when setting wpForo settings to read user profile by IDs, it works:

/profile/USER_NICENAME/ [some accounts redirect to 404]
/profile/USER_ID/ [works like a charm, but i'd prefer names]

Any suggestions? Accounts affected have totally non-related and clean names.

Joonas Kolostov
Posts: 5
Topic starter
(@stopz)
Active Member
Joined: 2 years ago

I think there's a bug.

I created a forum topic that had a slug of ari-ee, one of the accounts nicename, and as i published the topic it said 404 page not foud. When i replaced it in mysql with ari-ee-kontakt and deleted all caches it just started working as expected.

Share: