Notifications
Clear all

wpForo 1.x.x [Solved] User Registration Defaulting to Admin Role (Number 2)

14 Posts
3 Users
0 Likes
1,095 Views
thorsten32
Posts: 11
Topic starter
(@thorsten32)
Active Member
Joined: 2 years ago

Hi there,

Interesting,....
the data set did not exist.
I inserted it as described.
Unfortunately, the new user is always still in the "Admin" user group.

Where would the setting be in the backend?

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@thorsten32 ,

I've also asked you delete the wpForo cache in the wpForo dashboard. Please delete it again and registera new user.

If your WordPress is a multisite installation just let us know.

Reply
thorsten32
Posts: 11
Topic starter
(@thorsten32)
Active Member
Joined: 2 years ago

Hello Robert,

Thank you very much for your patience.
I deleted the cache several times, including one more time today.
Unfortunately, the new user still has the "admin" role

Perhaps the entry from the DB table user_meta meta_value will help

a:55:{s:2:"ID";s:5:"11176";s:10:"user_login";s:7:"qtester";s:9:"user_pass";s:34:"$P$B3BmxrfTYP0/2WFZbHErRTvjWw9fFo0";s:13:"user_nicename";s:7:"qtester";s:10:"user_email";s:19:"q@ts-tester.de";s:8:"user_url";s:0:"";s:15:"user_registered";s:19:"2021-12-11 08:10:41";s:19:"user_activation_key";s:0:"";s:11:"user_status";s:1:"0";s:12:"display_name";s:6:"tets t";s:6:"userid";s:5:"11176";s:5:"title";s:8:"Mitglied";s:8:"username";s:7:"qtester";s:7:"groupid";s:1:"1";s:5:"posts";s:1:"0";s:9:"questions";s:1:"0";s:7:"answers";s:1:"0";s:8:"comments";s:1:"0";s:4:"site";s:0:"";s:3:"icq";N;s:3:"aim";N;s:5:"yahoo";N;s:3:"msn";N;s:8:"facebook";N;s:7:"twitter";N;s:5:"gtalk";N;s:5:"skype";N;s:6:"avatar";N;s:9:"signature";N;s:5:"about";s:0:"";s:10:"occupation";N;s:8:"location";N;s:10:"last_login";s:19:"2021-12-11 08:10:41";s:11:"online_time";N;s:4:"rank";s:1:"0";s:4:"like";s:1:"0";s:6:"status";s:6:"active";s:8:"timezone";s:0:"";s:18:"is_email_confirmed";s:1:"0";s:16:"secondary_groups";N;s:6:"fields";N;s:4:"name";s:5:"Admin";s:4:"cans";s:645:"a:35:{s:2:"mf";s:1:"1";s:2:"ms";s:1:"1";s:2:"mt";s:1:"1";s:2:"mp";s:1:"1";s:3:"mth";s:1:"1";s:2:"vm";s:1:"1";s:3:"aum";s:1:"1";s:2:"em";s:1:"1";s:3:"vmg";s:1:"1";s:3:"aup";s:1:"1";s:4:"vmem";s:1:"1";s:9:"view_stat";s:1:"1";s:4:"vprf";s:1:"1";s:4:"vpra";s:1:"1";s:4:"vprs";s:1:"1";s:2:"bm";s:1:"1";s:2:"dm";s:1:"1";s:3:"upa";s:1:"1";s:3:"ups";s:1:"1";s:2:"va";s:1:"1";s:3:"vmu";s:1:"1";s:3:"vmm";s:1:"1";s:3:"vmt";s:1:"1";s:4:"vmct";s:1:"1";s:3:"vmr";s:1:"1";s:3:"vmw";s:1:"1";s:4:"vmsn";s:1:"1";s:4:"vmrd";s:1:"1";s:3:"vml";s:1:"1";s:3:"vmo";s:1:"1";s:3:"vms";s:1:"1";s:4:"vmam";s:1:"1";s:4:"vwpm";s:1:"1";s:3:"caa";i:1;s:12:"vt_add_topic";i:1;}";s:11:"description";s:0:"";s:6:"utitle";s:5:"Admin";s:4:"role";s:13:"administrator";s:6:"access";s:4:"full";s:5:"color";s:7:"#FF3333";s:7:"visible";s:1:"1";s:9:"secondary";s:1:"0";s:9:"groupname";s:5:"Admin";s:11:"profile_url";s:51:"https://www.mysite.de/forum/portraet/qtester/";s:4:"stat";a:14:{s:6:"points";i:0;s:6:"rating";i:0;s:14:"rating_procent";i:0;s:5:"color";s:7:"#d2d2d2";s:5:"badge";s:16:"far fa-star-half";s:5:"posts";i:0;s:6:"topics";i:0;s:9:"questions";i:0;s:7:"answers";i:0;s:17:"question_comments";i:0;s:5:"likes";i:0;s:5:"liked";i:0;s:5:"title";s:8:"Mitglied";s:4:"rank";i:0;}s:10:"first_name";s:4:"tets";s:9:"last_name";s:1:"t";}

It is really a disaster as the users are logged in immediately and could manipulate forum posts.

Do you need more information about my website?
Boddypress is installed.
However, the registration is carried out by the wordpress form.

 

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@thorsten32 ,

Something is wrong with your forum installation. you've done some manipulation with the data or some plugin conflicts with wpForo. That was very strange that you hadn't the option in your database. The last thing I can suggest is enabling the "Role-Usergroup Synchronization" option In Dashboard > Forums > Settings > Features Tab. Then delete all caches again. Also, try to temporary disable other plugins.

If this doesn't help you should contact us via info[at]gvectors.com email address and let us check your database.

Reply
thorsten32
Posts: 11
Topic starter
(@thorsten32)
Active Member
Joined: 2 years ago

Hello Robert,

Since I have had a bad experience with synchronization before, I would not like to do it again.

Thank you for your offer. I will write to gvectors directly.

Reply
thorsten32
Posts: 11
Topic starter
(@thorsten32)
Active Member
Joined: 2 years ago

Problem solved:
After I rolled back the update to wpforo 2.xx and used the wpforo tools (clear cache, clean up), the user is now assigned the role "Registered" as expected.

Thanks for the help.
Thorsten

Reply
Page 2 / 2