Notifications
Clear all

wpForo 1.x.x [Solved] User Registration Defaulting to Admin Role (Number 2)

14 Posts
3 Users
0 Likes
981 Views
thorsten32
Posts: 11
Topic starter
(@thorsten32)
Active Member
Joined: 2 years ago

Hi there ,

the topic has already been discussed here: https://wpforo.com/community/wpforo-integration/user-registration-defaulting-to-admin-role/#post-40702

but unfortunately there is no solution for me here.
In WP, the standard role is set to "Subscriber" after registration - that works too.
In WPForo the user group "Registered" is set as the standard.
Nevertheless, the user group "Admin" of the forum is given to the newly registered user.

What do I have to do so that the user receives the "Registered" user group?
Thank you very much in advance for your support.
regards
Thorsten

wpForo Version
1.9.9.1
WordPress Version
5.8
7.4
13 Replies
Chris
Posts: 1962
Admin
(@chris)
Support Team
Joined: 1 year ago

Hi @thorsten32,

Please provide a screenshot of your usergroups page.

Reply
thorsten32
Posts: 11
Topic starter
(@thorsten32)
Active Member
Joined: 2 years ago

Hi Chris,

here is the screenshot of the user groups page and standard-role in WP

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9737

@thorsten32,

1. Please go to Dashboard > Forums > Dashboard and click the [Delete All Caches] button

2. Install the phpMyAdmin Plugin or use the phpMyAdmin database tool of your hosting cPanle, open the database and browse the wp_wpforo_usergroups table and make sure the Admin usergroup has "administrator" value in the role field, also make sure the Register usergroup has "subscriber" value in the role field:

 

Reply
thorsten32
Posts: 11
Topic starter
(@thorsten32)
Active Member
Joined: 2 years ago

Hello Robert

I did that - the subscriber was a contributor.

This change did not help. Users continue to automatically have the wpforo Admin role

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9737

@thorsten32 ,

What change do you mean? What were the existing values?

Please note, that you should register a new user to see the result.

Reply
thorsten32
Posts: 11
Topic starter
(@thorsten32)
Active Member
Joined: 2 years ago

@Robert,

Admin had administrator role.
Registered had a costumer role which I changed to a subscriber role. Then I did 2 test registrations. Both users still had the WPforo role of Administrator.

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9737

@thorsten32,

Ok, please execute this SQL command or change it manually in the wp_options table. The we should find the wpforo_default_groupid option and change the value to 3:

UPDATE `wp_options` SET `option_value` = 3 WHERE `option_name` = 'wpforo_default_groupid'

 

After the change, go to Dashboard > Forums > Dashboard and click the [Delete All Caches] button

 

Reply
Page 1 / 2
Share: