Notifications
Clear all

[Solved] User Registration Defaulting to Admin Role

7 Posts
3 Users
0 Likes
787 Views
activatevision
Posts: 38
Topic starter
(@activatevision)
Eminent Member
Joined: 3 years ago

We don't want new registrants to come in as Admins. We would like the default to be Contributor. How do I change that? Right now when a new member registers they show up in the WP users list as Admin. 

Thank you

6 Replies
Martin
Posts: 868
Moderator
(@martin)
Support Team
Joined: 6 years ago

Hi @activatevision,

This is a result of your wrong configuration. wpForo default Usergroup is the "Registered" usergroup not the admin. What is your "default" usergroup in the Dashboard > Forums > Usergroups admin page? Please change it to something else:

 

Reply
activatevision
Posts: 38
Topic starter
(@activatevision)
Eminent Member
Joined: 3 years ago

Thank you. That's what I thought - that I have configured it wrong. How exactly to change it? What are the steps? This is what mine looks like. I haven't been able to delete and recreate new synchonizations. Nor am I clear how to end up with the default as registered as you have here. 

Reply
activatevision
Posts: 38
Topic starter
(@activatevision)
Eminent Member
Joined: 3 years ago

I created a new user group and set it as default. I tried a new registration and it's still showing up as Admin. I'm not sure how to reset this correctly.

Reply
2 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@activatevision,

Why you think your new users are admin? And please leave a URL of your new user registration page. Do you use wpForo registration page?

P.S. make sure you use the latest 1.7.4 version of wpForo.

Reply
activatevision
(@activatevision)
Joined: 3 years ago

Eminent Member
Posts: 38

@robert 

Hello... thank you for jumping in. Here is the registration page: https://oceact.org/community/?foro=signup

Yes using 1.7.4 of WPforo.

As for why I think the admin is the default... it's what shows up as the role in the users list when a new registration enters the system.

See screenshot: I just created this new registration and it showed up in the list with the administrator role as default. We want that to be the contributor (standard) role.

Reply
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

The problem is in the WrodPress settings. You set the default user role Administrator. You should never do this:

Reply