Notifications
Clear all

[Solved] Users getting 2 emails

20 Posts
2 Users
2 Likes
307 Views
Posts: 38
Topic starter
(@urisil)
Trusted Member
Joined: 2 years ago

My users are getting two identical emails about 1 minute apart on new topics and I can't figure out why. Does anyone know where I should start looking to fix this problem?

19 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @urisil,

Let's start from what emails do they get? Please provide examples.

3 Replies
(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris I attached an image of two emails that I received 1 minute apart. They contain the same exact text of a user who created a new topic. 

What other information would you like me to provide?

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

Here's an image of the SMTP plugin sending two emails 1 minute apart.

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

This is an image of the email that is received.

Posts: 38
Topic starter
(@urisil)
Trusted Member
Joined: 2 years ago

Here's updated information which might shed some light:

It seems that posts are being posted twice for some reason. I've checked with the users who say that when clicking Add topic, there is some delay until it processes and when it completes, the topic is posted twice. Image attached.

14 Replies
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@urisil,

I see that you're using old theme of wpForo or even old version. Please provide wpForo version and make sure that you're using 2022 theme.

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris I'm on version 2.1.6 and using the classic theme. Using the 2022 theme will change the whole layout, right? I'd like to avoid that if possible because the users are not so open to change 🙄

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris I'm going with your suggestion and have changed the theme to 2022. I'll let you know if I see any difference. If you have any other suggestions in the meantime, please let me know.

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris So after switching to the 2022 theme, we're still getting two emails when a new topic is created. Any ideas what can cause this?

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@urisil,

please provide Forum URL.

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris The forum is a private organizational forum which requires a username and password to log in to the website. Is there any information I can get you?

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@urisil,

Please create an account and sent the account credentials to info[at]gvectors.com, let me know here that you have sent the email. If you are good with that.

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris I sent you an email with the login credentials.

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@urisil,

Created a topic in general forum, check your email please. It's one or two?

Posted by: @urisil

the topic is posted twice.

After publishing the Topic, I didn't face double topic issue.

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris I only received one email. One user told me that after clicking Add topic, it loaded for a while but did not seem do anything, but it did post without confirming that it posted. Did you see any issues like that? Any slowness?

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@urisil,

Nope, all clean. Didn't see any issue with adding a new topic.

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris OK, is there anything else you can think of that might cause it or do you think it's user error?

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@urisil,

It may be internet lag or something like that not sure about it, I'm not familiar to these things, I just think the function was called twice.

(@urisil)
Joined: 2 years ago

Trusted Member
Posts: 38

@chris thanks for your help!