Notifications
Clear all

wpForo 1.x.x Users Register as Subscriber but Assignment to Contributor is Not Working...

9 Posts
4 Users
1 Likes
1,758 Views
Posts: 38
Topic starter
(@activatevision)
Eminent Member
Joined: 3 years ago

Hello

We have an approval process in place USER registers in default role 'subscriber' and when Admin's A. recognize the email and B. approve their first post the USER then is assigned the CONTRIBUTOR/Staff role. The admins are approving the post in moderation and changing the role there. However, the roles were not updating in the WP Users panel - not all of them. Some were and some were not. When I manually came in to change the role it would revert to Subscriber. I notice in the Forum access panel the Contributor role is not listed. I was not able to figure out how to enable it here. What am I missing? 

Basically we need the assignment of Contributor to go smoothly because this is the access privileges of staff members coming into the forum.

See screenshots of how our set up looks.

 

8 Replies
Posts: 883
Moderator
(@martin)
Support Team
Joined: 7 years ago

@activatevision,

The user role setting has no any relation to wpForo. Just set the default User Role contributor in Dashboard > Settings > General Tab.

Then set the same Contributor as default Usergroup in Dashboard > Forums > Usergroup admin page and synchronize usergroups.

Then go to Dashboard > Forums > Dashboard and press the [Delete all caches] button.

After this, register and new user and check the user roles. The old users should be set to contributors manually, they don't become contributor automatically. 

 

Reply
7 Replies
(@activatevision)
Joined: 3 years ago

Eminent Member
Posts: 38

@martin Thank you. I did those steps exactly. So we now have some usergroup roles we don't need. How to delete roles we don't know in settings?

Reply
forummember
(@forummember)
Joined: 3 months ago

Trusted Member
Posts: 48

Hi @martin I follow your instruction but nothing change on my Contributor member. Still they cannot create a topic.

Reply
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2778

@forummember,

Please, Double Check that The User Role and the Usergroup are synchronized 100%.

Reply
forummember
(@forummember)
Joined: 3 months ago

Trusted Member
Posts: 48
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2778

@forummember,

scroll down at the Usergroups page and you will see that the Subscriber Usergroup is not synchronized as you have set two Usergroups for one User Roll, in that Case the User Role Cannot be synchronized with two Usergroup, Only with on. 

Reply
forummember
(@forummember)
Joined: 3 months ago

Trusted Member
Posts: 48
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2778

@forummember,

Ok got that,

Navigate to wpForo > Forums, and make sure that in all Categories and Forums you have set Contributor Access to Contributor Usergroup in Forum Permission field

Reply