Notifications
Clear all

[Solved] Get 404 Error After Migration Starts

13 Posts
2 Users
0 Reactions
4,325 Views
0
Topic starter

I have a working phpBB.  I was able to migrate it to wpforo on my dev server with your go2wpforo plugin and tested / added plugins I bought from you and configured and migrated successfully: https://dev.hcca.org/community/

Installed wpforo on production and then plugins/extensions I bought for it including go2wpforo.  WordPress reported a new version of wpfororo and plugins so I installed those.

Ran go2wpforo to migrate. It confirmed I had avatars and files manually migrated to correct fplders. Click to migrate and get the WordPress 404 error page a few minutes into migrating or syncing files.  I only see a few entries in one new table "brw_mg2wpforo" in phpmyadmin.  I tried migration a 2nd time and got same results.

WpForo is reporting all WP members in its members section

Any suggestions on how to migrate phpBB would be appreciated.

I did change "path" for wpForo from community to Forums on production.

9 Answers
0

@bbsemail,

So have you migrated phpBB successfully in Dev and Test websites?

Please leave some video or screenshots, so I could see the problem. There is no way to help you based on your description.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

0
Topic starter

Thanks for your help.

In WordPress, I go to Go2wpForo

1. click PHPBB and complete the Database connection form
2. click Connect and see "Set PHPBB File Paths"
3. It tells me path it wants and I copied avatars and content to these paths from phpBB
/home/hcca/public_html/wp-content/uploads/wpforo/source/upload
/home/hcca/public_html/wp-content/uploads/wpforo/source
4. click Next Step and get 4 OK for status
5. click Next Step
6. in summary section "PHPBB to wpForo Migration", it shows it will bring over 736 Users, 4 Forums, 1062 topics and 3787 posts
7. in the wpForo column it shows the 3304 Wordpress users, 1 Forum, 0 topics and 0 posts.
8. I select Simplified for Forum Layout and 500 for Items to import per cycle
9. I select to migrate Adminstrators to admin, bots to guest, Global Moderators to moderators, guests to guests, the 3 registered types to registered and supermod to moderator.
moderator and super moderator had 0 members in phpBB
10. Click Start Migration and OK at warning about duplicates if you do it more than once
This time, it gets to 28% and then I get the WordPress 404 error page for not found.  On previous attempts, I had not noticed any progress before getting the 404 error.  I can review logs and see what page it tried to redirect to / load that caused 404 if desired.

This post was modified 3 years ago by bbsemail
bbsemail Topic starter 20/07/2021 12:23 am

I built and have a dedicated Linux server with full root access, but it is running cpanel

0

@bbsemail,

Ok, we could look deeper if you send admin login details to support[at]gvectors.com email address.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

0
Topic starter

Not comfortable giving admin access to production Site with real user data.  Can I create a WP account with rights only to wpForo and then make that user a member of admin group of wpForo?  Or, what access do you need and how can I grant it?

Thank you

Robert Robert 21/07/2021 1:32 pm
Posted by: @bbsemail

Not comfortable giving admin access to production Site with real user data.  Can I create a WP account with rights only to wpForo and then make that user a member of admin group of wpForo?  Or, what access do you need and how can I grant it?

Thank you

Ok, then let's just discuss the issues and find what's wrong.

1. If you don't need current forum data, please uninstall wpForo (click uninstall button to delete all data and database tables), the uninstall button is located net to the deactivate button. Then use phpMyAdmin database tool to drop the brw_mg2wpforo table as well.

2. Then install wpForo and Go2wpForo tool again and set 10 instead of 200 item per step and start the new migration.

4. Please take a video of the whole process you're doing. I mean, how do you start the migration.

5. Make sure your hosting has appropriate disk space for database and file system.

6. Let us know the PHP and MySQL versions

0
Topic starter

What login details do you need?  I don't have any wpForo users who aren't WordPress users and "hid" the registration form per your posted instructions.  Do you need a "regular" WordPress account or a WP admin account?

Is there a secure way to provide you with login details? Or is email best?

Again, thanks for the help.

Brad

This post was modified 3 years ago by bbsemail
0
Topic starter

Sent you an email but forgot server info.

hcca.org is running php version 7.3.28.  PHP version 7.4 breaks phpBB

mySQL Server version: 5.7.35

This post was modified 3 years ago 2 times by bbsemail
Robert Robert 21/07/2021 2:46 pm
Posted by: @bbsemail

Sent you an email

Please follow my instructions. We'll not login and we'll not use the login details, you can remove the user. Just do the steps I asked you.

 

0
Topic starter

As I said, last time I uninstalled wpForo it removed WordPress.  I have nightly backups but would rather not go that route.  Can you assist with details  I provided in email and here or should I risk a remove / reinstall wpForo?

0
Posted by: @bbsemail

As I said, last time I uninstalled wpForo it removed WordPress.

wpForo doesn't have any function to remove WordPress. This is impossible. That was something else. Please uninstall wpForo, install it again and try to migrate phpBB with the configuration I mentioned above.

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.

0
Topic starter

Thanks for your help.  Saw a new version of WordPress and installed ver 5.8 after our nightly backup. Saw an update to wpforo in WordPress admin so installed it and was able to run the migration of phpBB to wpForo without issue.

Looking good so far with all plugins I bought from you installed and working.  Wish I knew what changed.  However, now I'm getting these obvious spam emails quite a few times a day, including the gramar error:

HelloAdministrator,

The following is an e-mail sent to you through the administration contact page on "HCCA Forums".The message was sent from a guest who specified the following contact information:

...

I'm not seeing an "administration contact page".  How is it being accessed, how do I customize it, and how do I make it so only logged in users can use it?

This is probably more for you general help forum; I allow both YouTube insertion and uploading / embedding a video.  Can I set specific max file size allowed to upload for images and a separate value for mp4 videos?  How?  How do I remove the ability to upload/insert a video if I decide I don't want to offer that?

Again, looking forward to making your very promising Forum software available to our users.  Oh, and I got very positive feedback on your Private Messaging addon and the notification icon that appears.

Robert Robert 28/07/2021 4:02 am

@bbsemail,

Posted by: @bbsemail

HelloAdministrator,

The following is an e-mail sent to you through the administration contact page on "HCCA Forums".The message was sent from a guest who specified the following contact information:

Hmm... This is not sent by wpForo. Please check other plugins and the theme. wpForo has zero relation to this issue. I don't know what is this, this is not wpForo forum plugin issue for sure. This could be even the old phpBB forum email.

 

Posted by: @bbsemail

This is probably more for you general help forum; I allow both YouTube insertion and uploading / embedding a video.  Can I set specific max file size allowed to upload for images and a separate value for mp4 videos?  How?  How do I remove the ability to upload/insert a video if I decide I don't want to offer that?

All questions related to the addons should be asked in the gVectors Support forum with your customer account: https://gvectors.com/forum/

 

Posted by: @bbsemail

Again, looking forward to making your very promising Forum software available to our users.  Oh, and I got very positive feedback on your Private Messaging addon and the notification icon that appears.

it's nice to hear that!