Notifications
Clear all

wpForo 1.x.x Email Text from WpForo ignores line breaks

32 Posts
5 Users
5 Likes
2,799 Views
andredebonk
Posts: 22
Topic starter
(@andredebonk)
Eminent Member
Joined: 2 years ago

Hello!

 

Please see the attachment how I set the emails in wpforo.

Text version:

<p><strong>420.bible</strong></p><p> <br />Username: [user_login]<br /> </p><p>You joined the Khalasar.<br /> <br />Set your password:<br />[set_password_url]</p>

 

However, the received email is displayed in one single line. How to make it normal?

31 Replies
andredebonk
Posts: 22
Topic starter
(@andredebonk)
Eminent Member
Joined: 2 years ago

When I had Ultimate Member installed, I loved how the emails looked there, please see the attachment.

ย 

Is it possible to stylish wpforo emails to look similarly?

Reply
6 Replies
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9373

Hi @andredebonk,

Please let me know what version of wpForo you use. And how about the registration form? What registration form you use? Is that the UM registration form?

Where we can check it?

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

Hey @robert

 

wpForo Version 1.7.7

 

I deleted UM plugin, because when it is installed, it ignores wpForo settings regarding which profile should be used for the website (it always uses UM plugin)

 

So I have wpForo installed and Buddypress.

 

It is possible to register through the user icon at the top:

 

 

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

Which shows the registration window

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

If a user is registered in this way, he gets the email which is set in wpForo settings, but all the text is one line:

 

 

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

If the user registers through the wpForo page:

https://420.bible/Khalasar/?foro=signup

 

He gets an email that shows the text which is not set in wpForo settings:

 

 

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

And this if how it set in wpForo setting

Reply
Robert
Posts: 9373
Admin
(@robert)
Support Team
Joined: 6 years ago

Hi @andredebonk,

Try to disable wpForo email template overwriting. Go to Dashboard > Forums > Settings > Emails Tb and disable these options:

  • Overwrite WordPress New User Registration Email for Admins
  • Overwrite WordPress New User Registration Email for Users
  • Overwrite WordPress Reset Password Emails
Reply
12 Replies
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@robert after doing so, it sends emails like shown in my previous comment:

https://wpforo.com/community/postid/43525/

 

It sends it both for wpforo registration and from the main page.

This is not the result I am trying to achieve.

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9373

@andredebonk,

So just let me know what you want to exclude from this email?

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@robert I want to have control over the text that is being sent.

 

I expected that I can set it in wpForo settings.

 

However, when I register through wpForo, I get a standard text that ignores the text set in wpForo settings.

 

If I register through the login button at the top part of the website, it sends me the text set in wpForo settings, but it is sent in one line without line breaks.

 

My goal is that wpForo text would be sent in the proper way (with working line breaks), and that wpForo text would be sent when I register through wpforo registration.

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9373

@andredebonk,

The line-break issue is not general. It's hard to find why this issue exists on your website. We need admin access to check the problem and fix it. Please send it to info[at]gvectors.com email address and refer to this support topic.

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@robert I followed the instructions and sent the email

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9373

@andredebonk,

Ok, we'll check it within next 12-24 hours.

Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9373

@andredebonk,

Ok, we just tested and didn't see any issues with the line-break. Here is the screenshot, all works fine:

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@robert

 

This message is not set in wpForo settings, I don't have control over it.

It is actually one of the problems that I am reporting.

 

Have you seen that there are two ways to register?

 

One through the top login icon – it sends the text set in wpForo in one line.

Another is through wpForo signup page. As you can see from your screenshot, you got the message that is not set in wpForo settings.

 

Please check my messages in this thread, I have provided screenshots to better explain it.

 

My goal is to:

1. Make sure that users registering through wpForo signup page get the text, that is set in wpForo settings for registering new users.

2. Make sure that the text received is displayed properly (not in one line)

 

Thank you!

Reply
Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 866

@andredebonk,

Could you please configure wpForo in the way that we could see the problem?

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@martin you already see it

 

The screenshot that you shared contains not the text set in wpForo settings.

 

As you can see, I showed you the same screenshot and explained that it is wrong:

https://wpforo.com/community/postid/43525/

 

Because in wpForo settings it is set like this:

https://wpforo.com/community/postid/43526/

 

So when a new user registers through wpForo, he is not getting registration email set in wpForo settings.

He gets some default text that doesn't exist in my wpForo settings.

 

And if user registers in this way:

https://wpforo.com/community/postid/43522/

https://wpforo.com/community/postid/43523/

 

Then he gets the email set in wpForo settings, but it shown as one line:

https://wpforo.com/community/postid/43524/

 

 

Reply
Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 866

@andredebonk,

Ok, I know the issue, but I need to see it in real to be able to debug and find the problem maker point on your website. So If I register a new user will the email be one line (w/o line breaks)? I don't want to go through settings. So I'm just asking you to enable the settings which will make emails one-line.

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@martin all the settings are already set, you don't need to change them

 

This is what is set in wpForo settings, pay attention to the text:

https://wpforo.com/community/postid/43526/

 

The bugs which you can already see:

1. You got the wrong text when you registered through wpForo.

It doesn't correspond to the text set in the settings:

https://wpforo.com/community/postid/43526/

 

Instead, you get the default text.

 

2. To see a one-line email, you need to register in this way:

https://wpforo.com/community/postid/43522/

https://wpforo.com/community/postid/43523/

 

So you basically just press the button at the top of the site, enter username and email, and press Register.

Reply
Robert
Posts: 9373
Admin
(@robert)
Support Team
Joined: 6 years ago

@andredebonk,

All is clear. This is not a wpForo bug and this has no chance to be fixed from wpForo side. BuddyPress filters wpForo email template and changes it to non-HTML. If you want to use ByddPress user registration from, then you should disable wpForo email templates explained above: https://wpforo.com/community/postid/43570/

Then you can manage BuddyPress Email templates in Dashboard > Emails admin page. These are all BuddyPress email templates:

ย 

If you want to use wpForo Email Templates, then you should use wpForo Registration form. There is no other solution here.

Reply
2 Replies
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9373

You can change all wpForo registration menus and links to BuddyPress registration page using the according option in Dashboard > Forums > Settings  >Members Tab:

Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@robert thank you for finding the reason

 

So it is not possible to keep the active BuddyPress plugin and have a properly working wpForo Registration form, since BuddyPress has a higher email priority, right?

 

The text that users are getting with registering through wpForo also can't be found in BudyPress Emails.
Seems like the plugin just prevents the correct work of wpForo and it sends the default registration text instead of the custom one set in the settings.

 

So right wpForo has conflicts with Ultimate Member (if installed, it will be used as a site profile ignoring wpForo settings)

 

And also conflicts with BudyPress (if installed, wpForo emails settings don't work properly)

 

Please consider either making fixes for this (since it looks like your plugin is expected to work properly with them) or adding info about such issues to the FAQ.

Reply
andredebonk
Posts: 22
Topic starter
(@andredebonk)
Eminent Member
Joined: 2 years ago

@robert @martin

ย 

I have tried disabling Buddypress and WpForo plugins, but by some reasons the emails are still being sent with that text.

I don't know what overrides budypress or wpforo texts ๐Ÿ™

I checked Login with Ajax and Woocommerce, they shouldn't cause the problem.

ย 

Can you help to find out why wpforo emails can't be prioritized on my wordpress?

Reply
Page 1 / 2
Share: