Notifications
Clear all

wpForo 1.x.x Email Text from WpForo ignores line breaks

32 Posts
5 Users
5 Likes
3,062 Views
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago
Posted by: @andredebonk

So it is not possible to keep the active BuddyPress plugin and have a properly working wpForo Registration form, since BuddyPress has a higher email priority, right?

Yes, you're right.

Reply
1 Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@robert when I disable BudyPress plugin and enable all overrides in wpforo settings, I get the following situation:

 

When I register in this way:

https://wpforo.com/community/postid/43522/

 

I get the text set in wpforo settings, and it is formatted properly.

 

However, when I register with wpforo sing up page:

https://wpforo.com/community/postid/43525/

 

I keep getting another text.

 

So by some reason, the registration with wpforo ignores the text set in wpforo settings.

Once again, budypress is disabled, so it is not responsible for this problem.

Reply
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago
Posted by: @andredebonk

So right wpForo has conflicts with Ultimate Member (if installed, it will be used as a site profile ignoring wpForo settings)

 

And also conflicts with BudyPress (if installed, wpForo emails settings don't work properly)

These are not conflicts. You're installing profile plugins so you should use those plugins' registration functions and features. The user registration email is also a part of the registration features.

In other words, if you're using some profile plugins then you should use that plugins' registration features. Because they are created for that purpose, there is no mean to install a profile plugin and use forum registration features.

So this is not a conflict, this is a normal. wpForo should allow profile plugins to dominate. If you don't want it, just disable them and use only wpForo.

Reply
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago
Posted by: @andredebonk

Can you help to find out why wpforo emails can't be prioritized on my wordpress?

1. Make sure you've disabled all plugins which affects the email. Then make sure wpForo email overwriting is enabled. Go to Dashboard > Forums > Settings > Emails Tab and enable these options:

  • Overwrite WordPress New User Registration Email for Admins
  • Overwrite WordPress New User Registration Email for Users
  • Overwrite WordPress Reset Password Emails

 

2. Make sure you have not changed the registration URL in Dashboard > Forums > Settings  >Members Tab.

3. Then make sure wpForo registration and reset password replacement options are enabled in Dashboard > Forums > Settings > Features Tab:

  • Replace Registration Page URL to Forum Registration Page URL
  • Replace Reset Password Page URL to Forum Reset Password Page URL
Reply
1 Reply
andredebonk
(@andredebonk)
Joined: 2 years ago

Eminent Member
Posts: 22

@robert I tried doing so, but if register with wpforo it still sends the wrong text:

https://wpforo.com/community/postid/44714/

Reply
Alex666
Posts: 1
(@alex666)
New Member
Joined: 11 months ago

Same problem here....

Reply
1 Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@alex666,

Please create a new topic and describe your issue, also provide screenshots in the topic.

Reply
Page 2 / 2