Notifications
Clear all

[Closed] Problem with URL/permalink structure using wpForo with BuddyPress

9 Posts
3 Users
0 Reactions
489 Views
Posts: 9
 TNG
Topic starter
(@tng)
Active Member
Joined: 8 months ago

I'm installing wpForo on a staging site. Because of this I have no cache plugins active. I've also excluded the wpForo page from my cache plugins as is recommended in the documentation. 

I don't know if what I am experiencing is a bug, or an oversight.

The problem I'm having is that wpForo is inserting "community" in the URL where it should be inserting "forums".

For example: https://(base domain)/members/*whatever-user-name*/community/

The above example URL results in an error 404 as "community" should be "forums". I had used community originally but decided to stick to forums. I've deleted the cache in wpForo>Overview in addition to a Hard Flush for permalinks. I also reset permalinks from WP Admin settings. 

Any ideas? Am I overlooking something? 

8 Replies
BlackRaz
Posts: 406
Admin
(@blackraz)
Contributor
Joined: 8 years ago

Hello @tng,

Could you please share the URL of the website where you encountered the issue?

Posts: 9
 TNG
Topic starter
(@tng)
Active Member
Joined: 8 months ago

It is on a staging site. To make a long story short it is like the original slug (community) never updated when the slug was changed. It only happens in links generated by wpForo. Links we are not able to change.

1 Reply
BlackRaz
Admin
(@blackraz)
Joined: 8 years ago

Contributor
Posts: 406

@tng 

https://www.youtube.com/watch?v=g1QaLioiNPk

Posts: 9
 TNG
Topic starter
(@tng)
Active Member
Joined: 8 months ago

Thanks! That's where I changed the slug from community to forums. After having done that is when the problem started. I dug around to see if there was another place to change the slug, but all I found was the actual forums page which also uses the slug "forums". Is there anywhere else I should be looking?

2 Replies
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2610

@tng Check the slug in BOARDS settings

 TNG
(@tng)
Joined: 8 months ago

Active Member
Posts: 9

@dimalifragis Thanks! I changed the slug in wpforo>boards then i looked in wpforo>settings>board settings. The only slugs in board settings that could be changed are add topic, recent, and tags. 

I did see an option there to turn off the cache. I did that and tried resetting permalinks, but still no luck. 

BlackRaz
Posts: 406
Admin
(@blackraz)
Contributor
Joined: 8 years ago

If you want real help, please send us the website URL so that we can see the actual problem.

1 Reply
 TNG
(@tng)
Joined: 8 months ago

Active Member
Posts: 9

@blackraz Can I send you a PM with login info?