Notifications
Clear all

[Solved] Using Buddypress with wpForo

7 Posts
2 Users
0 Likes
793 Views
mafan
Posts: 9
Topic starter
(@mafan)
Active Member
Joined: 3 years ago

Hi,

I already read those articles

https://wpforo.com/community/how-to-and-troubleshooting-2/need-help-with-wpforo-and-buddypress/

https://wpforo.com/community/how-to-and-troubleshooting-2/how-to-properly-use-wpforo-with-buffypress/

Yet I have troubles when I click on my user profile : http://www.gay-naturiste.com/naturisme/membres/advitam007/

I have a 404 error page.

I have already tried to

- uncheck "Turn WordPress to wpForo" option, then delete all caches and then check it again

- unactivate wpForo, clear all caches and then activate it again

But I still have this 404 error page.

Do you have any idea to help me please ?

Mafan

Topic Tags
6 Replies
Robert
Posts: 9701
Admin
(@robert)
Support Team
Joined: 6 years ago

@mafan,

Please deactivate wpForo and activate it again.

Go to Dashboard > Forums > Settings > General Tab and press [update options] button below this admin page. And please lave a screenshot of that Tab here to allow me understand forum slug settings.

5 Replies
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9701

Also, please make sure the "Turn WordPress to wpForo" option is disabled.

mafan
(@mafan)
Joined: 3 years ago

Active Member
Posts: 9

@robert

Here is what I have when the "Turn WordPress to wpForo" option is disabled.

mafan
(@mafan)
Joined: 3 years ago

Active Member
Posts: 9

@robert

Thanks for your help!

Please find the screenshot of that tab with the forum slug settings

Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9701

@mafan

Please disable the "Turn WordPress to wpForo" option. If this option is enabled all other pages will be 404. Please read the description of that option before using it. Just disable it, delete all caches and use the original method to set forum on home page: https://wpforo.com/docs/root/getting-started/forum-page/set-forum-on-home-page/

Please never use this option if you have other pages on website front-end.

Next step is BuddyPress configuration. You should go to BuddyPress Settings and make sure all pages are sett correctly, then navigate to Dashboard > Pages and find all those pages, make sure those exist, then open those pages.

Don't forget delete wpForo cache in Dashboard > Forums > Dashboard admin page, then use private browser tabs to test, to avoid browser caches.

mafan
(@mafan)
Joined: 3 years ago

Active Member
Posts: 9

@robert

Thanks a lot, it works now !

Share: