Notifications
Clear all

[Closed] gtmetrix performance tests

37 Posts
7 Users
10 Reactions
3,583 Views
Posts: 1159
(@percysgrowroom)
Noble Member
Joined: 5 years ago
  1. Reduce your plugins

    Done some of this, will do more, this is workingΒ 

  2. Optimize or reduce size of your website images

    I thought this was done automatically by shortpixel, but it isnt, and i have 25k images to optmise lol, but this is being done too

  3. Install Autoptimize to optimize your website script

    What settings would you recommend for autoptmise if you dont mind me asking?

  4. Uninstall yoast because this plugin is heavy and not needed when using wpforo

    Will this effect my SEO in the front end of my site?Β 

  5. Optimize your database

    Being done tomorrow πŸ™‚

  6. Change your theme to generatepress

    Looking into a lighter theme and these seem like a great option. Used a page builder fo some pages, so i have to delete that and fix those pages too, mission, but again, im working on it

  7. Only using one layout for wpforo, in my experience threaded layout is fastest

    I dont mind sacrificing a bit of speed for a nice look πŸ˜‰Β 

  8. Reduce "Post Preview and Draft Saving" auto drafting interval= 1 minute, max number of revision= 3

    I have this disabled fully

  9. Deactivate statistic on wpforo

    What is that?

  10. Deactivate custom avatar, using gravatar only

    Again, my users prefer their own avatars so have to sacrifice some speed here

  11. Disable socialmedia sharing features

    I dont think i have these enabled

All coming on nicely though, thanks for everyones help here. I hope everything is up to speed within a few days.Β 

Some advice on the correct setting for autoptmise would be great if some one knows that info?Β 

10 Replies
adisaputro
(@adisaputro)
Joined: 5 years ago

Estimable Member
Posts: 127

@percysgrowroom,Β 

If you using cloudflare, you don't need to disable avatar because the image of avatar would be served from cloudflare cdn, so you can skip that,

This is my setting for autoptimize plugin:

  • Optimize javascript code?= yes
  • Aggregate JS-files?= yes
  • Also aggregate inline JS?= no
  • Force JavaScript in <head>?= no
  • Exclude scripts from Autoptimize= wp-includes/js/tinymce/,jquery.js
  • Add try-catch wrapping?= yes
  • Optimize CSS Code?= yes
  • Aggregate CSS-files?= yes
  • Also aggregate inline CSS?= yes
  • Generate data: URIs for images?= yes
  • Inline and Defer CSS?= no
  • Inline all CSS?= no
  • Exclude CSS from Autoptimize= admin-bar.min.css, dashicons.min.css
  • Optimize HTML Code?= yes
  • Keep HTML comments?= no
  • CDN Base URL= empty (I'm not using this feature)
  • Save aggregated script/css as static files?= yes
  • Minify excluded CSS and JS files?= no
  • Enable 404 fallbacks?= yes
  • Also optimize for logged in editors/ administrators?= no

Clicked on Extra Tab, this is my settings:

Your setting can be different from me based on plugins on your website and because I'm only using Ad Manager as WpForo addon.

After uninstall Yoast, your article on blog (not forums topic/post) that indexed by Google would be affect but this temporary and after that you can resubmit your sitemap (using built-in WordPress sitemap). WpForo has own SEO systems, I think Yoast and WpForo is not trully compatible and have cause some SEO conflicts.

You can optimize your database using WP-Optimize plugin, after that you can delete that plugin.

Don't using page builder, because that was "heavy" and can slow your site.

Below your site you can see forum statistic, deactivate that because that will recalculate and make your server slow. You can deactivate by clock Forums -> Settings -> Features Tab -> Show Forum Statistic, change to "no".

Β 

(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1159

@adisaputroI copied all of these settings, and set up cloud flare, changed over the databases, but its still slow lol

Its as if i have done nothing.....

frustrating. Looks like I have to get a new themeΒ 

adisaputro
(@adisaputro)
Joined: 5 years ago

Estimable Member
Posts: 127

@percysgrowroom

Make sure you already activate cloudflare proxy and set cache to standard.

I think your problem is TTFB you can google it,

Are you using VPS or shared hosting?, if using VPS, make sure you improve VPS setting based your operating system and webserver software, example nginx or apache..

I'm using shared hosting without problem and can load fast.

adisaputro
(@adisaputro)
Joined: 5 years ago

Estimable Member
Posts: 127

I saw forum statistic on your site is still active, you can deactivating that and you can see speed improvement.

(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1159

@adisaputro

Thanks mate!

But its coming to a point where i am going to loose more functionality to my site than I am happy with.Β 

I like to have the statistic there. So I have to loose some page speeed for that and some other things

It is very frustrating to say the least. I am not going to be able to get my site up to the speed of this one, or any where near close.Β 

It runs a lot faster now, Lightspeed seemed to work best for me. Along with cloud flare, but there are still some issues.Β 

I am on VPS hosting with A2.Β 

I dont have time to do any more of this today so all the problems are going to have to stay there.Β 

Pretty much, i feel like the only way im going to get my wpforo up to a decent speed, is by using a lot less plug ins. This included the add ons.Β 

Then I have to find a new really light theme, and it wont look great πŸ™Β 

Very disappointing really, I have put a lot of time into making this forum, but I dont think it will be able to reach the speed i want it to, without getting rid of too much functionality and the overall look of the site.Β 

Thanks for your help mate. My site is running much faster now though. I appreciate all your help. But I just dont think its worth it any more. It wont get much faster than what it is without sacrificing user experience.Β 

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2612

@percysgrowroom

Because you have NOT indentified (yet) the cause of your slowness. Cloudflare will not help you (in this stage) and will only make debuging impossible.

(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1159

@dimalifragis its all right mate, not really after you help! I dont want my lack of experience and knowledge to encourage you to be a d**k like last time we spoke.Β 

Plenty of nice helpful people here willing to help, just for the sake of helping! They dont do it to make themselves feel good, by belittle people.Β 

Im not interseted in anything you have to sayΒ 

adisaputro
(@adisaputro)
Joined: 5 years ago

Estimable Member
Posts: 127

@percysgrowroom

Now try to change the theme to lighter theme and my suggestion is GeneratePress, that theme is free to use and have great customer support even we using free version.

Reduce your widget and get rid page builder.

(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1159

@adisaputro Thanks bro, I really appreciate you taking all this time to help me out! Ill will give this a go πŸ™‚

GOt a very busy day today, so I have to carry on this work tomorrow. I will let you know how things go under the new theme πŸ™‚Β 

(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1159

@dimalifragis Sorry man, I dont mean to get arsey. Stressful few days, and what you said in the thread the other day rubbed me up the wrong way

I shouldn't be taking this tone with you regardless, my apologies.Β 

Posts: 1159
(@percysgrowroom)
Noble Member
Joined: 5 years ago

thanks man, great advice.Β 

I have tried all the plug in, and seem th think lightspeed cache works well, so far any way, this allowed me to move all of the databases to innoDB easily.Β 

Page builder is something i am going to get rid of, but i have to redesign the pages it would effect first.Β 

Im setting up cloudflare now πŸ™‚ ill let you know how that goes

Page 3 / 3