Creating the forum ...
 
Notifications
Clear all

wpForo 1.x.x [Closed] Creating the forum structure

10 Posts
2 Users
1 Reactions
669 Views
Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago

I've seen several problems when creating the structure.

1. It's confusing, there are several apparent ways to add main and sub categories.

2. Using the "Add new" button at the top:

I entered the first category. I can then click on "Add new" again at the top, to enter a new one. It actually discards my current category without any warning. One has to click on "Publish" to save it first.

If I click on "Add new" and there is nothing new to save, I sometimes have the "Leave site?" warning as if I were about to lose data.

3."Save forum order and hierarchy"

If I click on this button after changing the order, I get the "Leave site?" warning as if I were about to lose data, when I'm explicitly asking to save them!

4. Moving items in the hierarchy.

It's not possible to move an item under a same category and change its place. Moving it will only allow to place it under another another item which was previously at the same level. So if under "A", I have sub-categories "1", "3" and "2", if I move "2" after "1", it will actually put it as sub-category of "1".

Since creating items put them in the wrong order (last first), this is very cumbersome.

 

There are other issues but I'll stop there for now. I must say I'm hesitant to continue...

9 Replies
dimalifragis
Posts: 2612
(@dimalifragis)
Famed Member
Joined: 4 years ago

Before doing all that, press F12 and watch your browser CONSOLE for errors. That could be it.

An other possibility is plugin conflicts. You can check for those by using Standard Wordpress debug to a log. And check the log.

Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago

I have no error with the "Add new" not registering my current entry and not giving any warning.

When I click on publish to register the new entry, then on "Save forums order and heriarchy", I get the warning (leave?). I can't open the console before confirming the pop-up, but if I open it after, I see 1 error:

admin.php?page=wpforo-forums:349 Uncaught ReferenceError: navMenuL10n is not defined
at admin.php?page=wpforo-forums:349:4

3 Replies
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2612

@redglyph Ok, so there is a conflict with something. Do you have any other plugins installed?

(@redglyph)
Joined: 2 years ago

Active Member
Posts: 14

@dimalifragis No, the default plugins are disabled.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2612
Posted by: @redglyph

@dimalifragis No, the default plugins are disabled.

ok, while default plugins are safe, you have no plugins installed. Just WP and wpForo. So definitely is something with your setup. Maybe some dependancies are missing?

Please follow my suggestion to the other topic and enable debug.

 

Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago

I could not enter text after the quote in my previous post, so I'm continuing here.

I had other issues (here), which are more concerning, so I'll probably wait to see if that can be solved before trying anything else. There is apparently a conflict between WordPress and wpForo in what we can choose with the permalinks. Maybe that's just my server config, but it's quite standard.

3 Replies
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2612

@redglyph No there are no issues between a stock Wordpress installation and wpForo. None.

It is something specific with your setup, local from what i understand.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2612
Posted by: @redglyph

I could not enter text after the quote in my previous post, so I'm continuing here.

I had other issues (here), which are more concerning, so I'll probably wait to see if that can be solved before trying anything else.

I would start to solve why Wordpress permalinks can't be changed. And leave wpForo issues second.

(@redglyph)
Joined: 2 years ago

Active Member
Posts: 14

@dimalifragis I agree, first things first 🙂