wpForo and Elemento...
 
Notifications
Clear all

[Solved] wpForo and Elementor Pro. Noticed a bug

9 Posts
2 Users
3 Likes
119 Views
Adler11
Posts: 90
Topic starter
(@adler11)
Estimable Member
Joined: 2 years ago

Hello! I am addressing an interesting problem concerning wpForo and Elementor. I created my website (all pages) using Elementor. The result is admirable in its beauty (sorry for my excessive modesty), but one unpleasant moment hurts my perfectionist feelings and violates the harmony of Nature. Namely: forum pages behave a bit strangely on mobile devices - tablets and smartphones. It doesn't seem to catch your eye much, but it gets on your nerves. When you rotate the device screen, some ugly indentation appears on the right. See the screenshot:

Topic Tags
8 Replies
Adler11
Posts: 90
Topic starter
(@adler11)
Estimable Member
Joined: 2 years ago

Another screenshot:

Reply
Adler11
Posts: 90
Topic starter
(@adler11)
Estimable Member
Joined: 2 years ago

One more:

Reply
Adler11
Posts: 90
Topic starter
(@adler11)
Estimable Member
Joined: 2 years ago

I have several sites for experiments, so: if you embed wpForo into a site without using Elementor, then everything is displayed PERFECTLY, without bugs! For example, your site is displayed absolutely correctly. But if you use Elementor, the bug immediately appears. Even if you do a "clean" installation, on a completely new site. Although, in this case, the indentation is clearly less. But he is! This is clearly visible on the main page of the forum.

And yes, one more addition: all other pages of the site, except for the forum, are displayed perfectly correctly! Hurtful.

Is it possible to find the cause and fix this bug? Or am I doing something wrong? In any case, I ask for help! Because I don't want to give up Elementor at all.

Reply
Tutrix
Posts: 775
(@tutrix)
Prominent Member
Joined: 2 years ago

Hi @adler11

add this to custom css

#wpforo #wpforo-wrap .wpfl-2 .wpforo-forum .wpforo-forum-data {
overflow: hidden;
}

Dashboard > Forums > Settings > Style (custom css)

Reply
4 Replies
Adler11
(@adler11)
Joined: 2 years ago

Estimable Member
Posts: 90

@tutrix,

Unfortunately, it didn't help, BUT!!! Your idea turned out to be productive! It helped (see screenshot):
Thanks!

Reply
Tutrix
(@tutrix)
Joined: 2 years ago

Prominent Member
Posts: 775

@adler11 

clear the forum and browser cache

Reply
Adler11
(@adler11)
Joined: 2 years ago

Estimable Member
Posts: 90

@tutrix,

Thank you, everything worked out, albeit in a slightly different way. The cache didn't even have to be cleaned. It turns out that Elementor has the ability to hide Overflow sections by simply switching. So, my forum is now displayed perfectly correctly! Thank you for your help!

Reply
Tutrix
(@tutrix)
Joined: 2 years ago

Prominent Member
Posts: 775

@adler11 

ok, now it works for me on your forum too 😉 

Reply
Share: