Notifications
Clear all

wpForo 1.x.x [Solved] Cant translate to spanish

6 Posts
3 Users
0 Likes
734 Views
crwhntt
Posts: 5
Topic starter
(@crwhntt)
Active Member
Joined: 1 year ago

Hello,

I've set up wpForo on my webpage. Wordpress instalation is set to "Spanish" and wpForo is displaying in Spanish correctly.

There are some phrases I want to change but Im unable to.

I instaled "Loco Translate" and tried to update some phases, heres the screencap: http://prntscr.com/1a1ffrf

After Sincronizing and Saving, I cant see any difference on the frontend. Even after I clear Cache on Dashboard > Forums, and looking on a new private tab without any cache. Here is the screenshot with the phrase not updating: http://prntscr.com/1a1fy0m

 

I also tried to delete Loco Translate and translating manually on "/wp-content/plugins/wpforo/wpf-languages/wpforo-es_ES.po", but changes are not being applied.

 

I use Loco Translate on other plugins and all works, what is happening?

Topic Tags
5 Replies
5 Replies
Tutrix
(@tutrix)
Joined: 2 years ago

Prominent Member
Posts: 706
Posted by: @crwhntt

and wpForo is displaying in Spanish correctly.

There are some phrases I want to change but Im unable to.

have you tried using the wpForo integrated phrase system? 

Quick Translation – Phrases

Posted by: @crwhntt

I also tried to delete Loco Translate and translating manually on "/wp-content/plugins/wpforo/wpf-languages/wpforo-es_ES.po", but changes are not being applied.

do you have the wpforo-es_ES.mo in this folder too?

crwhntt
(@crwhntt)
Joined: 1 year ago

Active Member
Posts: 5
Posted by: @tutrix
Posted by: @crwhntt

and wpForo is displaying in Spanish correctly.

There are some phrases I want to change but Im unable to.

have you tried using the wpForo integrated phrase system? 

Quick Translation – Phrases

Posted by: @crwhntt

I also tried to delete Loco Translate and translating manually on "/wp-content/plugins/wpforo/wpf-languages/wpforo-es_ES.po", but changes are not being applied.

do you have the wpforo-es_ES.mo in this folder too?

Hello @tutrix,

Yes, I tried with the wpForo integrated phrase system, but nothing changes neither. ( http://prntscr.com/1ajtxpa)

Indeed there it is, here is the screencap: http://prntscr.com/1ajt2a0

And the phrase I put as example is translated in that "wpforo-es_ES.po" file. Here is the screencap: http://prntscr.com/1ajte7q

I am deleting cache everytime I make changes, just in case.

Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9373

@crwhntt,

Why the original phrases are not in English? You've damaged the phrase system, so the translation doesn't work. All original phrases should be in English, you should not touch them. Please remove all new added phrases which doesn't have English phrase key, edit the English phrases and only change the phrase value to Spanish.

It's better to use the Loco Translate plugin. Just create a new translation for your language, make sure the files are stored outside wpForo plugin, for example in /wp-content/languages/plugins directory and translate them. The translation will be automatically shown once you've changed the WordPress language to Spanish in Dashboard > Settings  >General admin page.

crwhntt
(@crwhntt)
Joined: 1 year ago

Active Member
Posts: 5
Posted by: @robert

@crwhntt,

Why the original phrases are not in English? You've damaged the phrase system, so the translation doesn't work. All original phrases should be in English, you should not touch them. Please remove all new added phrases which doesn't have English phrase key, edit the English phrases and only change the phrase value to Spanish.

It's better to use the Loco Translate plugin. Just create a new translation for your language, make sure the files are stored outside wpForo plugin, for example in /wp-content/languages/plugins directory and translate them. The translation will be automatically shown once you've changed the WordPress language to Spanish in Dashboard > Settings  >General admin page.

Okay storing the translated files inside wpforo directory was the issue apparently. Now its working.

 

I want to translate wpforo-polls addon too tho. I've placed the files in the same directory as the wpforo translation files but its not working, its all in english still: http://prntscr.com/1arwwwd

Translation example: http://prntscr.com/1arx493

Translation not working on frontend: http://prntscr.com/1arxdko

I sync'd and deleted the cache btw.

 

Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9373

@crwhntt,

I think this is a cache issue.

1. Check /wp-content/languages/ folder and delete all files related to the addon

2. Check /wp-content/languages/loco/ folder and subfolders, make sure there are no files related to the addon, delete them if any is found.

3. Delete all caches, then delete wpForo cache in Dashboard > Forums > Dashboard admin page.

4. If nothing helps, delete the translation file you've created and create it again in the same folder.

 

For further support, please open a new topic in gVecotrs Support forum: https://gvectors.com/forum/, here we don't support addons related issues. I'm closing the topic here.

Share: