Notifications
Clear all

[Solved] Complicated user registration process

22 Posts
4 Users
5 Likes
324 Views
Adler11
Posts: 90
Topic starter
(@adler11)
Estimable Member
Joined: 2 years ago

Hello! On my site, after registering a new user (if the person did everything correctly), the user appears on the login form with blank fields. That is, he is NOT IN THE SYSTEM! Although the admin receives an email that a new user has registered and if you look at this new user in the backend, you will see that he is ACTIVE, that is, the registration went fine. But this new user himself has to enter his username and password again to log in. Is it possible to configure the system so that a new user immediately remains logged in when registering? Confirmation of registration by mail is disabled (because half cannot see this email, so I disabled this option for a long time), there are NO caching plugins. Disabled it because these plugins don't want to work correctly with the Main Menu.
I am grateful in advance for the answer.

21 Replies
Robert
Posts: 9739
Admin
(@robert)
Support Team
Joined: 7 years ago

@adler11,

Ok, we'll check this.

Reply
1 Reply
Adler11
(@adler11)
Joined: 2 years ago

Estimable Member
Posts: 90

@robert,

By the way, it is because of this that there are many registered users who have not written a single post! They don't know that after REGISTRATION, you also need to LOG IN.

Reply
Adler11
Posts: 90
Topic starter
(@adler11)
Estimable Member
Joined: 2 years ago

I tried it on another site with wpForo newly installed, everything works as it should. New registered users remain logged in immediately. It's not like that with me. After registration, you also need to log in! I couldn't find anything suspicious in the settings. Strange. And what to do?

Reply
Adler11
Posts: 90
Topic starter
(@adler11)
Estimable Member
Joined: 2 years ago

Fixed the problem myself. Thank you all.

Reply
dimalifragis
Posts: 1663
(@dimalifragis)
Noble Member
Joined: 2 years ago

So, is that a secret? What was it? Maybe someone else could benefit in the future ....

Reply
1 Reply
Adler11
(@adler11)
Joined: 2 years ago

Estimable Member
Posts: 90

@dimalifragis,

Many third-party plugins that add Google reCAPTCHA v3 cause such an unpleasant effect. wpForo has v2 built in, but it generally acts irritatingly on users, especially on mobile devices. Therefore, I stubbornly tried to screw v3, but, as a result, abandoned this idea. I will wait for dear developers to change the built-in v2 to v3, or add a simple arithmetic checkbox, which would be even better! 😉 

Reply
Page 1 / 2
Share: