Notifications
Clear all

wpForo 1.x.x [Solved] Email notifications to admin and users suddenly stopped

9 Posts
3 Users
4 Likes
534 Views
jeanne
Posts: 76
Topic starter
(@jeanne)
Trusted Member
Joined: 6 years ago

A few days ago I switched three subscribers to moderator status, made some modifications in their settings and changed the color of the word Moderator from blue to black.  Around the same time, email notifications just stopped and I can't figure out why.  I'd appreciate any help with this. 

8 Replies
Robert
Posts: 9737
Admin
(@robert)
Support Team
Joined: 7 years ago

@jeanne,

Please specify what email notifications are stopped, there are lots of email notification types. Also, whose email notifications are stopped?

Are they subscribed to the forums and topics? They can check it and manage their subscriptions in My Profile > Subscription Tab.

Also, they can receive notifications about new topics and posts if their emails are inserted in the corresponding field of the Forums > Settings > Emails admin page.

Reply
3 Replies
jeanne
(@jeanne)
Joined: 6 years ago

Trusted Member
Posts: 76

@Robert All email notifications are not working. Until three days ago, the administrator (me) and subscribers received:

Administrator notification via email on new post and on new topic

Subscriber notification via email on new post and new topic

New reply notification email subject and message

New topic notification email subject and message

User mention message subject and body

Also bell notifications have never shown up on the forum.  I think I have to activate them but I'm unsure how to do this.

This stoppage happened soon after I made these changes:

I changed the color of the word Moderator from blue to black.

I changed three subscribers' status from subscriber to moderator, and changed some of the privileges for moderators, first adding them, then unchecking them, then adding them again. 

I did not empty the forum cache afterwards, but did empty it today, hoping it would restore notifications. 

 

Reply
jeanne
(@jeanne)
Joined: 6 years ago

Trusted Member
Posts: 76

I discovered the problem was with the host, GoDaddy.  Their security system had flagged and blacklisted the site because of all the email notifications the forum was sending to subscribers. Apparently when a Wordpress site is part of their shared hosting program, the host may flag it and prevent it from sending out emails.  They thought it was spam when it was just wpforo plugin sending new reply and new topic email notifications to the subscribers. It's been fixed now.

But I wonder if anyone else here has had that problem. GoDaddy said that if I hadn't corrected it with them, my site's reputation could have been harmed by being blacklisted. 

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9737

@jeanne,

I think you should use some SMTP service with this plugin:

https://wordpress.org/plugins/wp-mail-smtp/

  1. SMTP.com (Recommended)
  2. Sendinblue SMTP (Recommended)
  3. Mailgun SMTP
  4. SendGrid SMTP
  5. Gmail SMTP
  6. Microsoft SMTP (Outlook.com and Office 365)
  7. Amazon SES SMTP
  8. Zoho Mail SMTP
  9. All Other SMTP
Reply
dimalifragis
Posts: 1663
(@dimalifragis)
Noble Member
Joined: 2 years ago

Find and move to a good hosting company.

@robert Gmail smtp is not a good solution.

Reply
jeanne
Posts: 76
Topic starter
(@jeanne)
Trusted Member
Joined: 6 years ago

@Robert and @dimalifragisThank you for the suggestions.  Page loading is also too slow now no matter what we do. I welcome any suggestions for website hosts who are reliable.  This forum (wpforo/community) is always up and running but GoDaddy has dropped the ball on me about once a year over the last four years. 

I would appreciate suggestions for website hosts from people who run wpforo sites that are about the same size as this one. I get about 360,000 pageviews a month.

Reply
dimalifragis
Posts: 1663
(@dimalifragis)
Noble Member
Joined: 2 years ago

I would like to correct my comment above.

Checking your site, it seems that it is not an issue with Godaddy but issues due to Wordpress conflicts/errors. Also you use Sucuri proxy_whatever and maybe also something wrong is with all that complexity. Slowness included.

Reply
1 Reply
jeanne
(@jeanne)
Joined: 6 years ago

Trusted Member
Posts: 76

@dimalifragis. Thank you for this observation. I will think further about  having too many operations going on at the same time.

 

Reply
Share: