Notifications
Clear all

Fatal error after updating plugins to 3.x.x and before installing Wpforo 2.x

8 Posts
2 Users
0 Likes
52 Views
maxelio42
Posts: 72
Topic starter
(@maxelio42)
Estimable Member
Joined: 3 years ago

Hi,

I followed your instructions and updated my four addons to 3.x.x before updating to Wpforo 2.x.

But I can't do this last update, and cannot access anymore to my Wordpress dashboard. The error displayed is :

Fatal error: Uncaught Error: Call to undefined function wpforo_is_module_enabled()
in /home/clients/3a49d058a1babb770daa11d5a8da262a/les-castors/wp-content/plugins/wpforo-advanced-attachments/includes/functions.php on line 21

Pile d’appel :

  1. {closure}()
    wp-includes/class-wp-hook.php:307
  2. WP_Hook::apply_filters()
    wp-includes/class-wp-hook.php:331
  3. WP_Hook::do_action()
    wp-includes/plugin.php:476
  4. do_action()
    wp-content/plugins/wpforo/wpf-admin/admin.php:66
  5. wpforo_add_menu()
    wp-includes/class-wp-hook.php:307
  6. WP_Hook::apply_filters()
    wp-includes/class-wp-hook.php:331
  7. WP_Hook::do_action()
    wp-includes/plugin.php:476
  8. do_action()
    wp-admin/includes/menu.php:155
  9. require_once()
    wp-admin/menu.php:394
  10. require()
    wp-admin/admin.php:158
  11. require_once()
    wp-admin/index.php:10

 

Any help please?...

7 Replies
Chris
Posts: 1593
Admin
(@chris)
Support Team
Joined: 1 year ago

Hi @maxelio42,

please check this FAQ Topic: https://wpforo.com/community/faq/instruction-to-update-to-wpforo-2-0-solutions-for-auto-update-problems/#post-68095

Reply
1 Reply
maxelio42
(@maxelio42)
Joined: 3 years ago

Estimable Member
Posts: 72

@chris 

I don't get you.

Should I update Wpforo BEFORE updating advanced attachments addon (v 3.0.1)?

Please my messages below.

 

Reply
maxelio42
Posts: 72
Topic starter
(@maxelio42)
Estimable Member
Joined: 3 years ago

I used the recovery mode offered by Wordpress to desactivate the advanced attachments addon (v 3.0.1), and now I can access my backoffice again.

I tried to suppress this addon and reinstall it, but the same issue came back!

Reply
2 Replies
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1593

@maxelio42,

update wpForo to 2.x and then activate the addons(their version should be 3.x)

Reply
maxelio42
(@maxelio42)
Joined: 3 years ago

Estimable Member
Posts: 72

@chris 

Few... It worked, thanks!

Reply
maxelio42
Posts: 72
Topic starter
(@maxelio42)
Estimable Member
Joined: 3 years ago

So, I replaced 3.0.1 version by the old 2.1.2 version.

I let the other three addons (Embed/Polls/Private messages) in 3.0.0 version, and my Wpforo plugin is still in 1.9.9.2.

But I suppose this is not a good solution?

What should I do now?...

Reply
1 Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1593

@maxelio42,

If you are using wpForo 2.x then you should use addons 3.x

If wpForo is 1.9.x, the addons must NOT be 3.x only lower versions.

Reply
Share: