Notifications
Clear all

wpForo 1.x.x [Closed] Forum page loading issue

5 Posts
3 Users
0 Likes
917 Views
Muhammad Umar Farooq
Posts: 32
Topic starter
(@pkheart)
Trusted Member
Joined: 5 years ago

Hi,

Forum page is not loading properly taking too much time but still not fully loaded to make changes (tried wait option few times also), tried with other browser as well but with same issue. Below is video for reference.

https://www.screencast.com/t/h1KJWsoIWe

 

 

Topic Tags
4 Replies
dimalifragis
Posts: 2539
(@dimalifragis)
Famed Member
Joined: 4 years ago

Well with 2700 forums, what can we say ....

Try to increase your memory limit to 512 or more (you have now 256 that is low for such a big site).

Are your using a powefull hosting plan?

Muhammad Umar Farooq
Posts: 32
Topic starter
(@pkheart)
Trusted Member
Joined: 5 years ago
Posted by: @dimalifragis

Well with 2700 forums, what can we say ....

I was planing to add more ~1000 sub-forums 🤫 

 

Posted by: @dimalifragis

Try to increase your memory limit to 512 or more (you have now 256 that is low for such a big site).

Increased every thing, let me know if further any change is required.

memory_limit = 1024M
upload_max_filesize = 256M
post_max_size = 256M
max_execution_time = 240
display_errors = Off
date.timezone = "Europe/London"
error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT
session.save_path = "/tmp"
max_input_time = 240
max_input_vars = 20000
session.gc_maxlifetime = 1440
zlib.output_compression = Off

 

Posted by: @dimalifragis

Are your using a powefull hosting plan?

I am using N@meChe@p,[Shared] Stellar Business hosting.

 

 

Issue is still their, Can't load forums section...

dimalifragis
Posts: 2539
(@dimalifragis)
Famed Member
Joined: 4 years ago

Well, to rule out any issues, could you enable for a few minutes Wordpress DEBUG to a LOG and do what you do with admin and forum?

And then check that debug log for any issues?

About your set of 240 of max execution time, i think it is of no use because:

The set_time_limit() function and the configuration directive max_execution_time only affect the execution time of the script itself. Any time spent on activity that happens outside the execution of the script such as system calls using system(), stream operations, database queries, etc. is not included when determining the maximum time that the script has been running. This is not true on Windows where the measured time is real.

 

Robert
Posts: 10478
Admin
(@robert)
Support Team
Joined: 8 years ago

@pkheart,

Discussion Boards and all Forum Softwares are not designed to have thousands of forums. Instead of creating tons of sub-forums it's better to use different Topic Prefixes grouped by Prefix Groups and attached to certain parent forum. So, when users create a topic, they select a topic prefix. This groups all topics with related content and play sub-forum role.

So please consider using Topic Prefixes instead of thousands of sub-forums. You can find more information about topic prefixes in the addon page: https://gvectors.com/product/wpforo-topic-prefix/

BTW, I recommend change the wp_wpforo_forums table engine to MyISAM. Please use your cPanle > phpMyAdmin Database Manager tool, backup the wp_wpforo_forums table, check it, if it's not MyISAM, click the Browse button of this table, then find the Operations Tab above, click it, and change the table engine to MyISAM. This will help to read the forum data faster: