Notifications
Clear all

wpForo 1.x.x [Closed] Forum slowed down a lot

6 Posts
4 Users
1 Likes
923 Views
Posts: 1131
Topic starter
(@percysgrowroom)
Noble Member
Joined: 5 years ago

Hi, I have some issues withe the forum, when i like posts, or anything like that, its takes ages for the like to go through and the forum section of my site seems to be alot slower than usual.

Can you help me find out what the issue is? I think it may be one of my cache plug ins but not sure....

Percysgrowroom.com

5 Replies
Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

Impossible to tell, since you use caching, minifying, Cloudflare.

What you should do is first be sure that you are error free (Enable WP Debug to a log and check) and second disable all those i mentioned and check if the problem is gone. Then enable one by one.

Also check in Forum / Tools if you have any database errors and problems.

Also check your browser console, you are several js errors.

 

Sofy
Posts: 4136
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @percysgrowroom,

I'd also suggest you read this support topic. Here Robert mentioned the common reasons why wpForo is slow: 

https://wpforo.com/community/faq/forum-is-slow/

Posts: 1131
Topic starter
(@percysgrowroom)
Noble Member
Joined: 5 years ago

I got rid of the w3 cache plugin, and only using auto optimise, with the foum code excused from it, nd everything is working fast now. 

I have all of the add ons for wpforo, is there a way to combine all of the code together into one plug in? So i can reduce the amount of plugin my sites has? 

10 of my plugins are wpforo.... It would be great if i could compress them into one plug in if that was possible. 

1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4136

Hi @percysgrowroom,

I have all of the add ons for wpforo, is there a way to combine all of the code together into one plug in? So i can reduce the amount of plugin my sites has? 

I'm sorry, but not. 

In case of cache plugin, you can simply disable it for wpForo pages.  All cache plugins should have an option to disable caching for certain page. The main wpForo page is the one which contains [wpforo] shortcode. In most case, it's example.com/community/. You should disable other cache plugins for example.com/community/*.

I'd also recommend you check the other points of the support to make sure there are no other issues.

Posts: 111
(@nando4)
Estimable Member
Joined: 7 years ago

@Robert, as https://wpforo.com/community/faq/forum-is-slow/ is a closed topic, I'll post the question here.

I enabled log-queries-not-using-indexes=1 in /etc/my.cnf and see a stack of unindexed mysql wpforo queries though they are like the two examples shown below.

Can indexes be added to improve their performance? Am using INNODB for all wpforo tables with MariaDB.


# User@Host: xxxxx [yyyyyyy] @ localhost []
# Thread_id: 975 Schema: my_db QC_hit: No
# Query_time: 0.002725 Lock_time: 0.000087 Rows_sent: 1 Rows_examined: 16099
# Rows_affected: 0 Bytes_sent: 72
SET timestamp=1559974383;
SELECT COUNT(l.`likeid`) FROM `wp_wpforo_likes` l, `wp_users` u WHERE `l`.`userid` = `u`.ID AND `l`.`postid` = 8043;

# User@Host: xxxxx [yyyyyyy] @ localhost []
# Thread_id: 571 Schema: my_db QC_hit: No
# Query_time: 0.010828 Lock_time: 0.000054 Rows_sent: 1 Rows_examined: 207
# Rows_affected: 0 Bytes_sent: 76
SET timestamp=1559974006;
SELECT tmp_view.`rownum` FROM
(SELECT @rownum := @rownum + 1 AS rownum, p.`postid`
FROM `wp_wpforo_posts` p
CROSS JOIN ( SELECT @rownum := 0 ) AS init_var
WHERE p.`topicid` = 5446
AND NOT p.`status`
ORDER BY `is_first_post` DESC, `created` ASC, `postid` ASC) AS tmp_view
WHERE tmp_view.`postid` = 61140;