Notifications
Clear all

Script Generate forum link wrong

7 Posts
3 Users
1 Likes
1,155 Views
niennguyen84
Posts: 3
Topic starter
(@niennguyen84)
New Member
Joined: 1 year ago

I deploy wordpress on kubenute, and installed wpforo plugin (the last version)

Sometimes wpforo genenate link is wrong, I set forum base url to https://www.tkaraoke.com/forums  but it generate  to https://localhost:8080  

See the forum page: https://www.tkaraoke.com/forums

6 Replies
Chris
Posts: 2665
Admin
(@chris)
Support Team
Joined: 2 years ago

Hi @niennguyen84,

Can you give us more information about the issue you have and make screenshots

Reply
niennguyen84
Posts: 3
Topic starter
(@niennguyen84)
New Member
Joined: 1 year ago

WordPress: 5.8.1
PHP Version: 7.4.15
MySqL version: 10.5.6-MariaDB
WpForo: 1.9.9

Base forum url: https://www.tkaraoke.com/forums/
Seem The code source doesn't call from base forum url

Reply
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @niennguyen84,

Please navigate to Dashboard > Forums > Dashboard admin page and click the [Delete all Caches] button.

Reply
3 Replies
niennguyen84
(@niennguyen84)
Joined: 1 year ago

New Member
Posts: 3

Hi @robert,

 

I done, but it doesn't work.

 

Reply
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2665

@niennguyen84,

This is not a wpForo core related issue. The problem comes from the local to online transfer, which is not done correctly and clean.

You need to find a good Dev who will transfer the site correctly, or you can use WordPress Plugin to make the transfer, and also after the new transfer you should clean all the caches.

Reply
niennguyen84
(@niennguyen84)
Joined: 1 year ago

New Member
Posts: 3

@robert 

I  use ingress to controller out side request from user and ingress map to localhost service

Seem the forum code get baseurl from proxy (localhost service) instead of it use baseurl form setting to generate uri

Reply