Notifications
Clear all

wpForo 1.x.x How to let guests post

5 Posts
2 Users
0 Likes
2,714 Views
peterwangbiz
Posts: 54
Topic starter
(@peterwangbiz)
Trusted Member
Joined: 5 years ago

Can write PM - what PM mean?

If I would like to let guests post, how to set?

Thanks in advance!

 

Peter

Topic Tags
4 Replies
Robert
Posts: 9714
Admin
(@robert)
Support Team
Joined: 7 years ago

The PM permission is designed for wpForo Private Messages addon. You'll use that if you get this addon. Now you can ignore it.

To enable guest posting please navigate to Dashboard > Forums > Settings > Forum Access Tab, edit the Read Only access and enable "Can create topic", "Can post reply".... permissions.

To make guest posting secure navigate to Dashboard > Forums > Tools admin page and configure reCAPTCHA for Guest Topic and Post Editors.

Reply
peterwangbiz
Posts: 54
Topic starter
(@peterwangbiz)
Trusted Member
Joined: 5 years ago

Thank you very much!

 

"To enable guest posting please navigate to Dashboard > Forums > Settings > Forum Access Tab, edit the Read Only access and enable "Can create topic", "Can post reply".... permissions." ------- I've set  "Can create topic", it works. But there are two more problems:

1, when a visitor posted a new topic, it cannot appear, need be approved. How can I set to let a visitor can post directly without needing approved.

2, I've already set letting the visitors post with attachment, but no "attach button" appear in the visitor page (I can see this button in the admin page)

Could you please teach me how to do?

Thanks.

Peter

Reply
Robert
Posts: 9714
Admin
(@robert)
Support Team
Joined: 7 years ago

1, when a visitor posted a new topic, it cannot appear, need be approved. How can I set to let a visitor can post directly without needing approved.

I don't recommend this for spam reasons. However if you want to change this, just enable "Can pass moderation" permission for Guest Usergroup in Dashboard > Forums > Usergroups admin page. If this doesn't help, try to disable Spam Control in Dashboard > Forums > Tools admin page.

2, I've already set letting the visitors post with attachment, but no "attach button" appear in the visitor page (I can see this button in the admin page)

First set the "Min number of posts to be able attach files" option 0, in Dashboard > Forums > Tools admin page. Also please make sure the "Can attach file" and "Can view attached files" permissions are enabled for "Read Only" Forum Access in Dashboard > Forums > Settings > Forum Accesses admin page.

Reply
peterwangbiz
Posts: 54
Topic starter
(@peterwangbiz)
Trusted Member
Joined: 5 years ago

All done. Thank you very much!

 

Peter

Reply
Share: