Notifications
Clear all

wpForo 1.x.x How-to noindex a whole directories of pages?

10 Posts
3 Users
0 Likes
969 Views
plc123
Posts: 11
Topic starter
(@plc123)
Active Member
Joined: 3 years ago

Hi,

I'm having a big issue with your plugin due to a large amount of duplicated content.

I know it is possible to noindex a specific page in the "Misc" tab of the Tools section.

But how correctly remove a whole directory of pages using that tool?

For example, I tried: https://www.example.com/forum/activity/*  but it does not work.

Please, could you provide a snippet of code to achieve that result?

There are a lot of WpForo pages that are not needed to be indexed (no content).

 

Many thanks in advance

Topic Tags
9 Replies
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @plc123,

Please leave your forum URL.

Reply
1 Reply
plc123
(@plc123)
Joined: 3 years ago

Active Member
Posts: 11
plc123
Posts: 11
Topic starter
(@plc123)
Active Member
Joined: 3 years ago

I believe,

there is also a poor usage of the CANONICAL URL. In fact, many URIs with query parameters are being stored and shown as different results but actually they are not.

 

So, please, consider providing a good fix for the duplicate content issue.

 

The SEO section is almost missing in wpForo and this is a big problem.

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@plc123,

wpForo excludes almost all unnecessary URLs and adds noindex to them. So it would be better to provide an example URLs.

wpForo has an option to disable user profile indexing in Dashboard > Forums > Settings > Features admin page. The option name is "Enable User Profile Page indexing".

wpForo allows you to set noindex any forum topic and directory in Dashboard > Forums > Tools > Misc Tab. The option name is "Noindex forum page URLs".

wpForo has a sitemap so you can use it in the Google Webmaster tools. The sitemap link can be found in Dashboard  > Forums > Settings > General Tab.

 

 

Reply
plc123
Posts: 11
Topic starter
(@plc123)
Active Member
Joined: 3 years ago
Posted by: @robert

wpForo has an option to disable user profile indexing in Dashboard > Forums > Settings > Features admin page. The option name is "Enable User Profile Page indexing".

@robert . Thanks for this. Without having a specific SEO section, it wasn't easy to spot this. I disabled the indexing of these pages.

So, let's consider the following URI:

https://www.pietrolc.com/community/activity/piseth/

The source code contains two meta robots: the former has value "noindex", the latter has value "index, follow".

I think the Google Bot will be a bit confused about the action to take here. Could you double-check if this issue is depending on wpForo, please?

 

Posted by: @robert

wpForo allows you to set noindex any forum topic and directory in Dashboard > Forums > Tools > Misc Tab. The option name is "Noindex forum page URLs".

Correct, is this using regex? How can I apply a rule to the whole folder and subfolders? Do I need to put an asterisk to the end of the provided URI?

 

Posted by: @robert

wpForo has a sitemap so you can use it in the Google Webmaster tools. The sitemap link can be found in Dashboard  > Forums > Settings > General Tab.

Thanks for this. Very difficult to spot as well. I added the sitemap to Google Webmasters Tools.

 

Canonical URL:

Example: https://www.pietrolc.com/community/recent/?view=unread

Canonical URL: https://www.pietrolc.com/community/?view=unread

 

Question: is there a way to not include the query parameters in the canonical URL (especially when no content is available)?

 

Many thanks in advance,

Pietro

Reply
4 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@plc123

Posted by: @plc123

The source code contains two meta robots: the former has value "noindex", the latter has value "index, follow".

The later value is not the wpForo one. So all is clear. Your forum SEO tags are affected by other plugins. So please let me know what SEO plugin you use. i think you may consider changing it to other plugin which doesn't affect wpForo SEO.

Reply
plc123
(@plc123)
Joined: 3 years ago

Active Member
Posts: 11

@robert

Please, check the following report showing the amount of duplicated content on my website:

https://www.siteliner.com/www.pietrolc.com?siteliner=site-duplicate&siteliner-sort=match_words

 

You can verify the culprit is an issue in wpForo generating a lot of identical pages.

I decided to avoid indexing all those pages using a short code snippet.

Please, take a look into the number of identical pages being generated and seen by crawlers.

I think this issue should be fixed.

 

Hope this can help.

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@plc123,

Something is wrong on your forum. I've never seen such issue.

I'd recommend exclude all combinations of the recent posts pages by disabling the RSS feed in Dashboard  > Forums > Settings > Features admin page:

Reply
plc123
(@plc123)
Joined: 3 years ago

Active Member
Posts: 11

@robert

Something is wrong on your forum.

Unfortunately, yes.

 

I would like to keep the RSS functionality enabled to not lose a wpForo feature.

 

I'm using your plugin where the relative paths - defined somewhere - are causing some issues.

 

I wanted only to inform you of my findings. Please, double-check.

Reply