Notifications
Clear all

wpForo 1.x.x Leave a Reply with Spinning Progress Ball

4 Posts
2 Users
0 Likes
617 Views
pluto
Posts: 2
Topic starter
(@pluto)
New Member
Joined: 2 years ago

I am using wpForo Version 1.8.3 and I am getting a spinning progress ball on the leave a reply textbox. (screenshot attached).

Forum Link: https://pm.wisdomdepot.com/pmp-forum

I am using W3 Total Cache.  I've tried to inactivate the W3 Total Cache plugin and clear the cache, same issue.  I also tried activated W3 Total Cache and exclude the pages from

W3 Total Cache > Performance > Page Cache > Never cache the following pages:

/pmp-forum*
/pmp-forum/*

 

From Google Developer Console, I see the following error but I am not sure if it's related:

Uncaught ReferenceError: lazySizes is not defined
at share-your-pmp-exam-tips-and-success-story:1425
share-your-pmp-exam-tips-and-success-story:1425 Uncaught TypeError: Cannot read property 'editor' of undefined
at share-your-pmp-exam-tips-and-success-story:1425
share-your-pmp-exam-tips-and-success-story:1425 Uncaught ReferenceError: tinymce is not defined
at share-your-pmp-exam-tips-and-success-story:1425
e3b3a.js:2 Uncaught ReferenceError: tinyMCE is not defined
at e3b3a.js:2
at e3b3a.js:2
share-your-pmp-exam-tips-and-success-story:1425 Uncaught ReferenceError: tinymce is not defined
at Object.load_ext (share-your-pmp-exam-tips-and-success-story:1425)

 

Thanks in advance for your help!

Topic Tags
3 Replies
Alvina
Posts: 1872
Moderator
(@alvina)
Member
Joined: 3 years ago

Hi @pluto,

Please check all steps below to get it resolved:

1. Make sure the Visual editor is enabled for your account in Dashboard > Users > Your Profile admin page.

2. Your WordPress theme footer php file must contain  function to allow all plugins load JS files and scripts, so please make sure is exist. Scremshot below:

3. It also may be a theme conflict, so please switch to some default theme before checking.

Related topic below:

https://wpforo.com/community/general-forums-bug-reports/add-topic-and-reply-box-loading/#post-39031

Reply
pluto
Posts: 2
Topic starter
(@pluto)
New Member
Joined: 2 years ago

Hi @Alvina

Thank you for the response.  I made sure the Visual Editor is not disabled, and I am using Newspaper theme and it has wp_footer function before the </body>  (see attached).  

As far as the 3rd suggestion, I can't simply just switch theme as I have active users so switch back to default Wordpress theme is not a realistic option.  

I also saw another post: https://wpforo.com/community/how-to-and-troubleshooting-2/does-not-work-tinymce/
It seems tinyMCE is a common problem for modern themes.  According to the post "Once I switch to TwentySeventeen or I revert back to WP 4.9.9 everything is fine.  Or else, nothing in this world can make that TinyMCE editor work in wpForo on WP 5.x."

I am currently using WP 5.3.4, and I just installed WPforo's latest plugin update... still getting the spinning wheel.  

Reply
1 Reply
Alvina
Moderator
(@alvina)
Joined: 3 years ago

Member
Posts: 1872

@pluto,

Then, please deactivate the Cache or Minifier/Optimizer plugins if those exist, and check again.

Reply
Share: