Notifications
Clear all

wpForo 1.x.x [Solved] Login redirect and 404 issue

15 Posts
6 Users
0 Likes
4,285 Views
Robert
Posts: 9325
Admin
(@robert)
Support Team
Joined: 6 years ago

Ok, we see the proble. We'll fix this in next version. At the moment please check the Login Menu shortcode to ?wpforo=signin , please see the screenshot:

 

1 Reply
studio500
(@studio500)
Joined: 5 years ago

Trusted Member
Posts: 80

Ok, I have changed the login as directed.

Is it ok for me to leave my home page set to the default /community page for the time being ?

Robert
Posts: 9325
Admin
(@robert)
Support Team
Joined: 6 years ago
Posted by: studio500

Ok, I have changed the login as directed.

Is it ok for me to leave my home page set to the default /community page for the time being ?

That's not a good idea. The home page should be other page, not the main wpForo page.

pederw
Posts: 23
(@pederw)
Eminent Member
Joined: 5 years ago
Posted by: Robert
Posted by: studio500

Ok, I have changed the login as directed.

Is it ok for me to leave my home page set to the default /community page for the time being ?

That's not a good idea. The home page should be other page, not the main wpForo page.

Why is that not a good idea? I've done the same.in case you want the forum on the frontpage it will switch the home menu if you put it on another page. But if you put forum as home problem solved?

sworden
Posts: 13
(@sworden)
Active Member
Joined: 6 years ago

I have tried both of these fixes (making sure the login was /%wpforo-login%/ and changing it to ?wpforo=signin, and neither are correcting the 404 issue.  The URL is:

https://www.triadmathinc.com/community/http:/www.triadmathinc.com/community/

If I delete the second URL to after logging in:

https://www.triadmathinc.com/community/

I go to the forum as expected, but I can't tell all of our customers to do this.  Is there a solution?

4 Replies
Anonymous20
(@anonymous20)
Joined: 6 years ago

Noble Member
Posts: 1602
Posted by: sworden

I have tried both of these fixes (making sure the login was /%wpforo-login%/ and changing it to ?wpforo=signin, and neither are correcting the 404 issue.  The URL is:

https://www.triadmathinc.com/community/http:/www.triadmathinc.com/community/

If I delete the second URL to after logging in:

https://www.triadmathinc.com/community/

I go to the forum as expected, but I can't tell all of our customers to do this.  Is there a solution?

Fix all your links to https:

Some are http://

See your html source of this page:

https://www.triadmathinc.com/community/

sworden
(@sworden)
Joined: 6 years ago

Active Member
Posts: 13

Somehow I never saw this reply.  I looked at the code, and see where the http:// occurs, but I see that they are either in wpForo code that I can't find the access to, or in general WordPress theme settings that I can't find the access to.  How do I change them, as this login problem is still ongoing.

sworden
(@sworden)
Joined: 6 years ago

Active Member
Posts: 13

I was able to fix the login problem.  Changing http:// to https:// did not fix it.  After a bit of panic when my login would not show up at all, I realized that there was a conflict between the forum login and a login to something else on the site.  Renaming the Forum login to "Forum Login" and changing the URL once more to ?wpforo-signin fixed both the original problem and my disappearing login problem.

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

Thank you for letting us know and sharing the information. Glad to hear that the issue is solved. 

Page 2 / 2
Share: