Notifications
Clear all

wpForo 1.x.x Login tab not appearing

14 Posts
3 Users
0 Likes
1,114 Views
gav
Posts: 37
 gav
Topic starter
(@gav)
Eminent Member
Joined: 3 years ago

Users are reporting a problem when they try to log in to my forum. I have experienced the same problem. When they go to the main page, there is no Login tab to click on. The Register tab is also missing. I have found that when I click on one of the tabs that is available, such as Recent Posts, the Login and Register tabs do appear. How do I get them to display on the main page again?

wpForo Version
1.9.9
WordPress Version
5.8.1
13 Replies
dimalifragis
Posts: 1638
(@dimalifragis)
Noble Member
Joined: 2 years ago

Two issues that i found:

1. Litespeed cache. No caching for wpForo pages. Remove/exclude the page of wpForo from caching.

2. Your main/home page displays a strange error:

https://songwriterjunction.com/false

[HTTP/3 404 Not Found 173ms]

I have no idea what this is.

Reply
1 Reply
gav
 gav
(@gav)
Joined: 3 years ago

Eminent Member
Posts: 37

@dimalifragis Disabling the Litespeed cache seems to have worked - thank you for your speedy help!

I don't know much about Litespeed. It was automatically installed by my web host.

Reply
dimalifragis
Posts: 1638
(@dimalifragis)
Noble Member
Joined: 2 years ago

That is great.

Still your home page has some strange errors, not related with wpForo. Press F12 to see them in your browser console:

 

(1) songwriterjunction.com/:202 GET https://songwriterjunction.com/false 404

vendor~embed.20be87ed.js:1

 

(2)POST https://sentry.io/api/265628/envelope/?sentry_key=db1eaaeafb9044828c39cd41f9805164&sentry_version=7 429 (Too Many Requests)

Reply
dimalifragis
Posts: 1638
(@dimalifragis)
Noble Member
Joined: 2 years ago

Something else. I see in your wpForo pages "Litespeed Page Supported". Not 100% sure what that means, but Litespeed cache seems active. Partly?

Maybe not the caching but the Page Optimizations.

Reply
Robert
Posts: 9710
Admin
(@robert)
Support Team
Joined: 6 years ago

@gav,

You have two big issues on your website.

1. You've not excluded the forum page from the LiteSpeed Cache plugin. Please do that asap, here is the instruction: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

2. Your SSL certificate doesn't work. So the cookies cannot be stored, and the authorization cannot be kept correctly. You should fix the SSL certificate and read this topic: https://wpforo.com/community/faq/login-problem-menu-is-not-changed-and-weird-logged-in-behaviour/

Reply
1 Reply
gav
 gav
(@gav)
Joined: 3 years ago

Eminent Member
Posts: 37

@robert 

1. I disabled the Litespeed cache altogether and that seems to have solved the problem. I have also followed the instructions to exclude the home page of the forum so that if I ever enable Litespeed cache again, I will presumably not have the problem.

2.I don't know what you mean when you say the SSL certificate doesn't work. I read the topic you mentioned and checked that entering http://songwriterjunction.com does indeed redirect to https://songwriterjunction.com. However, if I enter http://songwriterjunction.com/community, it does not redirect to the https version. I don't know how to fix this specifically for the forum.

Reply
Page 1 / 2
Share: