Notifications
Clear all

wpForo 1.x.x Meta descriptions for forums not updating when crawled

8 Posts
2 Users
0 Likes
705 Views
UnpopularMechanics
Posts: 4
Topic starter
(@unpopularmechanics)
New Member
Joined: 3 years ago

I have a website forum with a bunch of subforums. Wpforo has been amazing so far, I'm just having an issue with the meta descriptions for the subforums not updating in search results. The main page meta description will update but not the subforums. The site has been crawled since I updated the descriptions (1 month ago) and when I view the crawled page the meta description is indeed not what is entered for the forum. I figured that it may just take a while to update but it's been a month. Could google just be taking the overall forum description and using it for each subforum? Thanks for any help!

Topic Tags
7 Replies
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi UnpopularMechanics,

Are you using some additional SEO plugins? If yes please exclude wpForo pages from the plugin's settings for providing optimal indexing of forum pages in search engines. 

Reply
UnpopularMechanics
Posts: 4
Topic starter
(@unpopularmechanics)
New Member
Joined: 3 years ago

No SEO plugins. I do have Smush and SG Optimizer though; could those be affecting the SEO?

Reply
1 Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

@unpopularmechanics

To tell the truth I'm not an SEO expert. I'm going to ask this question to wpForo developers. It'd be better if you also provide us your forum URL. 

 I do have Smush and SG Optimizer though; could those be affecting the SEO?

I don't think so. These plugins shouldn't have any effects on SEO. 

Reply
UnpopularMechanics
Posts: 4
Topic starter
(@unpopularmechanics)
New Member
Joined: 3 years ago

My url is:

https://feassistant.com

An example of a sub forum with the meta description not showing correctly:

https://feassistant.com/forums/ls-dyna/

Thanks!

Reply
3 Replies
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

Thank you @unpopularmechanics

I'll update the topic, once I get news for you. 

Reply
Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

Hi @unpopularmechanics,

Please try the solution mentioned by Robert in this support topic: 

https://wpforo.com/community/general-forums-bug-reports/shortcodes-inserted-into-the-page-changes-title/#post-25921

Reply
UnpopularMechanics
(@unpopularmechanics)
Joined: 3 years ago

New Member
Posts: 4

Okay I have changed the code and will request google for a crawl. I will keep you updated if it worked. Thank you!

Reply
Share: