Clear all

wpForo 1.x.x Meta Titles not Working

3 Posts
3 Users
Posts: 1
Topic starter
New Member
Joined: 4 years ago

I just installed wpForo and it's great but all the titles for the forum pages are showing the URLs of the pages instead of the actual Meta titles. I am using the Yoast SEO plugin if that makes a difference. How can I make it so that the titles are appearing correctly? I attached a picture showing what it looks like right now

Topic Tags
2 Replies
Posts: 1602
Noble Member
Joined: 7 years ago

@shiftisnow do your self two favors actually.

1. Remove that BAD-BAD W3 Total cache plugin. Or at least EXCLUDE wpForo pages from it. Otherwise you are doomed. I can't really express how bad this plugin (W3TC) is. A myth. wpForo has a build in caching.

2. Remove Yoast SEO. OR disable wpForo SEO. Can't have both. I would suggest to also EXCLUDE wpFORO pages from Yoast or even better switch to SEO FRAMEWORK all-together.

All in all you seem not to be familiar with wpForo. Spend some time to read the docs. You use caching and SEO that wpForo already has build-in. Not to mention two wrong selection of plugins, W3TC that is not recomended (and you do not even need such a heavy stuff, use WP Super Cache) and Yoast (the most heavy plugin for SEO i have seen).


Posts: 9979
Support Team
Joined: 7 years ago

Hi @shiftisnow,

I'd also recommend this solution. Put that code in your active WordPress theme functions.php file: