Notifications
Clear all

Performance Insert / Update New post

24 Posts
3 Users
3 Likes
1,087 Views
dimalifragis
Posts: 2137
(@dimalifragis)
Famed Member
Joined: 3 years ago

Finally if all the above doesn't provide any usefull information, enable standard Wordpress DEBUG to a LOG and check in there for errors.

 

https://wordpress.org/documentation/article/debugging-in-wordpress/

 

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
Reply
Posts: 18
Topic starter
(@argentetsalaire)
Eminent Member
Joined: 3 months ago

Posted by: @dimalifragis

@argentetsalaire OK, then the issue could be the outgoing email subscriptions. An email sending slowness. A slow smtp server or some related issue.

How do you send OUT the emails from wpForo?

An other thing to check:

Press F12 and watch your browser console for errors when you press to post a topic.

Each new post, i send about 50 emails notifications. I use WP Mail SMTP, witch uses the mail serveur that is on my CPANEL server. 

No consol error when i post a new post. 

But updating a old post is much faster. And when i update a post there are no email notification sent. So your idea about SMTP being the source of the problem is a good idea. 

Is there a way to send emails asynchronously, so that it doesn't penalize the creation of a new post?

Reply
3 Replies
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Famed Member
Posts: 2137

@argentetsalaire

Not my idea about email delay, it has been posted here very often.

You can maybe get some help using:

https://wordpress.org/plugins/gd-mail-queue/

a great piece of software.

Also enable debug log for a few hours, since your issue could be something else.

Reply
(@argentetsalaire)
Joined: 3 months ago

Eminent Member
Posts: 18

Posted by: @dimalifragis

@argentetsalaire

Not my idea about email delay, it has been posted here very often.

You can maybe get some help using:

https://wordpress.org/plugins/gd-mail-queue/

a great piece of software.

Also enable debug log for a few hours, since your issue could be something else.

I tried "gd-mail-queue", and it seems to resolve the problem. I need more testing but I was able to post a new message that was sent in like 3 seconds instead of 15. 

I still use de WP MAIL SMTP PRO + i use gd-mail-queue.

@dimalifragis thanks for the idea!

 

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Famed Member
Posts: 2137

@argentetsalaire Good to know i helped.

Disable wp_mail plugin, why use that? Two smtp plugins at the same time?

Reply
Posts: 18
Topic starter
(@argentetsalaire)
Eminent Member
Joined: 3 months ago

I tried to post a new message on two topics :

1 topic has 50 follower (sends 50 email) : Post validation takes 15 seconds

1 topic has 12 follower (sends 12 email) : Pos validation takes 5 seconds...

So that might be my problem but no idear to solve it. I don't know if gd-mail-queue/ is compatible with WP SMTP EMAIL PRO that i use.

Reply
Page 2 / 2