Notifications
Clear all

[Closed] Performance Insert / Update New post

24 Posts
3 Users
3 Likes
1,432 Views
Posts: 29
Topic starter
(@argentetsalaire)
Eminent Member
Joined: 1 year ago

I have a performance problème when publishing or updating a post. Publishing a new post can take up to 10 to 15 seconds.

I have no problem with displaying forum pages. The cache works well. 

I am hosted at https://www.o2switch.fr/hebergement-illimite/ : A 12 CPU / 48GO ram and use PHP 8 / 10.6.12-MariaDB

Is there a way to get better performance when publishing new posts ?

23 Replies
dimalifragis
Posts: 2593
(@dimalifragis)
Famed Member
Joined: 4 years ago

NO CACHING for wpForo.

https://wpforo.com/community/faq/wpforo-and-cache-plugins/#post-37150

You even got a warning about it when updating.

And you have TWO caches, REDIS and Rocket cache.

 

8 Replies
(@argentetsalaire)
Joined: 1 year ago

Eminent Member
Posts: 29

@dimalifragis I already exclude /forum/(.*) from Rocket.

No idea to exclude from Redis. But i already tried without Redis, and posting a message is still slow.

But my problem is not when reading the forum, but when inserting au new post in the database. It can take up to 10 to 15 seconds. The cache do not help going faster when inserting or updating the database. 

So my question is why creating a new post take so much time as i am hosted on a  12 CPU / 48GO ram site?

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2593

@argentetsalaire 

Please REMOVE ANY caching from your Forums. You didn't. Please do not say you did. Check your forum htlm source to see it.

... and two cachings active, it not very wise.

Solve this and if the issue persists, we will take it from there.

(@argentetsalaire)
Joined: 1 year ago

Eminent Member
Posts: 29

@dimalifragis  Ok I stopped Redis.

But For WP Rocket as you can see on this screenshot, /forum/ is excluded and in the cache folder of WP Rocket, there are no /forum/ files : 

I tried publishing a new post and it took 15 seconds

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2593

@argentetsalaire Do you read my replies? Did you read the link about caching posted by wpForo stuff?

Sorry, i think i can't help more.

(@argentetsalaire)
Joined: 1 year ago

Eminent Member
Posts: 29

@dimalifragis Yes i read the post and followed the WPROcket exclusion as you can see  on this screenshot.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2593

@argentetsalaire 

PLEASE follow the FAQ link i posted.

You are adding a BACKSLASH at the end, REMOVE IT.

/forum/(.*)

and NOT

/forum/(.*)/

and after that, check the HTML SOURCE to see if the CACHE is GONE.

Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1268

@dimalifragis 

the backslash is added automatically by wpRocket

(@argentetsalaire)
Joined: 1 year ago

Eminent Member
Posts: 29

@dimalifragis 

When i type "/forum/(.*)"

WP Rocket automatically replace with  "/forum/(.*)/" when i save the settings.

But it doen't seems to be a problem as i can see that WP ROCKET do not cache WPFORO any more. When i look in the WPROCKET cache folder, there are no /forum/ cache page.

Tutrix
Posts: 1268
(@tutrix)
Noble Member
Joined: 4 years ago

@argentetsalaire

use

/forum/
/forum/(.*)

3 Replies
(@argentetsalaire)
Joined: 1 year ago

Eminent Member
Posts: 29

@tutrix 

Yes i tried both. but as is told @dimalifragis, i am quite sure WP Rocket do not cache my forum as the wprocket forum cache folder is empty on the server.

 

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2593

Posted by: @argentetsalaire

@tutrix 

Yes i tried both. but as is told @dimalifragis, i am quite sure WP Rocket do not cache my forum as the wprocket forum cache folder is empty on the server.

 

 

NOW it is NOT caching. Disabled. Apparently you changed something and NOW it works right.

Is the performance issue solved?

 

 

 

Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1268

@argentetsalaire 

now "forum" is excluded from wpRocket cache 😉 

Posts: 29
Topic starter
(@argentetsalaire)
Eminent Member
Joined: 1 year ago

Posted by: @dimalifragis

NOW it is NOT caching. Disabled. Apparently you changed something and NOW it works right.

Is the performance issue solved?

I just add both 

/forum/
/forum/(.*)/

as @tutrix sugested. 

But no differences: The forum is still fast when reading posts, but still slow when publishing a new post. My host is providing a 12CPU and 48Go ram. I thaught, it could be faster. It takes 10 to 15 seconds to publish a new post.

2 Replies
Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1268

@argentetsalaire 

do you have the problem in every topic

or e.g. only in topic's with currently 1,851 posts and 75 pages?

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2593

@argentetsalaire OK, then the issue could be the outgoing email subscriptions. An email sending slowness. A slow smtp server or some related issue.

How do you send OUT the emails from wpForo?

An other thing to check:

Press F12 and watch your browser console for errors when you press to post a topic.

dimalifragis
Posts: 2593
(@dimalifragis)
Famed Member
Joined: 4 years ago

Also Query Monitor plugin will pinpoint from where the delay comes .....

 

https://wordpress.org/plugins/query-monitor/

Page 1 / 2