Notifications
Clear all

wpForo 1.x.x [Solved] PHP error, need help

29 Posts
4 Users
7 Likes
1,106 Views
Macky
Posts: 792
Topic starter
(@percysgrowroom)
Noble Member
Joined: 3 years ago

Hi all, my query monitor is telling me there is a lot of php errors from wpforo:

close() expects parameter 1 to be resource, bool given 649

  1. wp-content/plugins/wpforo/wpf-includes/functions.php:826
/public_html/wp-content/uploads/wpforo/cache/item/forum/142_en_GB): failed to open stream: No such file or directory 6

  1. wp-content/plugins/wpforo/wpf-includes/functions.php:824

How can I fix these?

28 Replies
Martin
Posts: 863
Moderator
(@martin)
Support Team
Joined: 6 years ago

The PHP Errors are already fixed in the core for the next update. You can fix it manually till the update release using this instruction: https://wpforo.com/community/general-forums-bug-reports/500-error/#post-49184

3 Replies
Macky
(@percysgrowroom)
Joined: 3 years ago

Noble Member
Posts: 792

@martin Thanks Martin.ย 

I have made the edit but still getting warnings:

public_html/wp-content/uploads/wpforo/cache/item/forum/142_en_GB): failed to open stream: No such file or directory

6

  1. wp-content/plugins/wpforo/wpf-includes/functions.php:824

Do you know when the next update wll be ready?ย 

Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 863

@percysgrowroom,

This change was for the first error. The second issue comes from your file system permissions. You can ignore that warning. Just delete all wpForo cache in Dashboard > Forum > Dashboard admin page and ignore the warning.ย 

For some reason the cache system of wpForo cannot find the cache files. You should make sure all files are readable in your server. Maybe you've transferred your website from one to another server, or maybe the owner of files is different. In any case this is something we cannot help you. You should check to make sure all folders have 755 permissions and files 644 permissions for:

  • /wp-content/
  • /wp-content/uploads/
  • /wp-content/uploads/wpforo/
  • /wp-content/uploads/wpforo/cache/
  • /wp-content/uploads/wpforo/cache/.....

ย 

BTW, if you use some security plugin you can disable it temporarily and check the warnings again.

Macky
(@percysgrowroom)
Joined: 3 years ago

Noble Member
Posts: 792

@martin Thanks Martin I appreciate your help! Ill look into all of this now

Macky
Posts: 792
Topic starter
(@percysgrowroom)
Noble Member
Joined: 3 years ago

Ok, I see youre right with the permissions. I have cloudflare installed, im going to get rid of that and do the test again, that might be changing the permissions?ย 

If that doesnt work, when in the file ot change it, do i just change the number from 755 to 644 or is there more for me to do?ย 

1 Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9262

@percysgrowroom,

You should change back folder permissions to 755 and all files to 644 using a FTP client like Filezilla.

I think this issue also affects forum speed because the forum cache cannot work if the file permissions are incorrect.

Macky
Posts: 792
Topic starter
(@percysgrowroom)
Noble Member
Joined: 3 years ago

awesome, i will fix it now ๐Ÿ™‚ thanks guys i will let you know how it goes

ย 

ย 

Macky
Posts: 792
Topic starter
(@percysgrowroom)
Noble Member
Joined: 3 years ago

You should check to make sure all folders have 755 permissions and files 644 permissions for:

  • /wp-content/
  • /wp-content/uploads/
  • /wp-content/uploads/wpforo/
  • /wp-content/uploads/wpforo/cache/
  • /wp-content/uploads/wpforo/cache/.....

I did this guys and it made things reallly bad lol.ย 

Which folder exactly should i set to 644?ย 

Page 1 / 3
Share: