Notifications
Clear all

wpForo 1.x.x PHP Error: Trying to get property of non-object in public_html/wp-content/plugins/wpforo/wpf-includes/wpf-hooks.php on line 34

6 Posts
3 Users
0 Likes
567 Views
yipiash
Posts: 13
Topic starter
(@yipiash)
Active Member
Joined: 3 years ago

Hi, 

When someone tries to Post a topic or reply to a topic, it keeps spinning for a while, then the spinner vanishes. But the page isn't updated with the new topic/reply (as it should without reloading the page). And after being stuck like this for some time, it shows a timeout error (524). But then if I come back to the original forum/post, I can see that the topic/reply was posted indeed. But that timeout error is also causing Memory spike on the server.

This is the error I see in the server log (I am on SiteGround cloud):

2021-01-16 15:24:58 UTC [apache][:warn] [pid 82157] [client 113.21.229.114:41980] Timeout waiting for output from CGI script /home/u2-p34x3jqdvcvm/www/bohubrihi.com/public_html/index.php, referer: https://www.bohubrihi.com/forums/excel-basics/

And here is the WordPress debug log at that exact time:

[16-Jan-2021 15:24:58 UTC] PHP Notice: Trying to get property of non-object in /home/customer/www/bohubrihi.com/public_html/wp-content/plugins/wpforo/wpf-includes/wpf-hooks.php on line 34

Recently updated to the latest Version 1.9.3, but same problem. 

I also have a clone of my site on AWS (EC2, nginx), the same issue happens there.

 

My forum root directory: https://www.bohubrihi.com/forums/

5 Replies
dimalifragis
Posts: 1635
(@dimalifragis)
Noble Member
Joined: 2 years ago

Hi.

 

1. "PHP Error: Trying to get property of non-object" is not an error but a notice.

2. Remove caching from your wpForo page. Right now you cache AND minify with FastestCache. You shouldn't.

And check again.

Reply
yipiash
Posts: 13
Topic starter
(@yipiash)
Active Member
Joined: 3 years ago

1. thanks.
2. I already tried it, and tried these as well: https://wpforo.com/community/faq/forum-is-slow/

Still those errors and notices are being logged and users see 504, 524 (apache) and 404(nginx) errors and memory surge as well.

Reply
dimalifragis
Posts: 1635
(@dimalifragis)
Noble Member
Joined: 2 years ago

ok, in any case permanently remove caching from wpForo page (exclude it).

With that disabled, press F12 and check your browser console for errors when writing/posting.

As for your debug log notice, i can guess that comes from some other plugin.

Reply
yipiash
Posts: 13
Topic starter
(@yipiash)
Active Member
Joined: 3 years ago

I have already deactivated the caching plugin and security plugins before testing the issue.

The console shows a 404(nginx) error after loading for a long time. You can see it yourself by trying to post here: https://aws.bohubrihi.com/forums/excel-forum-galib/ (you can create a free account and post)

Reply
Page 1 / 2
Share: