Notifications
Clear all

[Solved] Php8 upgrade causes a conflict

6 Posts
3 Users
0 Reactions
399 Views
Posts: 4
Topic starter
(@atom13)
Active Member
Joined: 1 year ago

Hello guys,

 

already used this topic here:

 

Php8 upgrade causes a conflict with the Woocommerce PDF voucher plugin – How-to and Troubleshooting – wpForo Support Forum

 

But until now i receive no answer from @chris.

 

So the issue is really urgent, therefore i open a new topic in hope to solve the problem really fast:

 

If i enable PHP 8 it will produce critical error. Can you update this when the Update for the plugin will be roll out? Or can you fix it directly in our page ?

Access i can give you for sure.

 

Many thanks

Topic Tags
5 Replies
Robert
Posts: 10525
Admin
(@robert)
Support Team
Joined: 8 years ago

@atom13,

wpForo has not been tested with PHP 8.1 yet. Please use PHP 7.x or 8.0.

1 Reply
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10525

BTW, please find error logs and leave it here. It seems the issue comes from WooCommerce PDF product vouchers plugin rather than wpForo.

Posts: 4
Topic starter
(@atom13)
Active Member
Joined: 1 year ago

hi again, i did not use woocommerce pdf product voucger plugin.

the log file i will send later on

Posts: 4
Topic starter
(@atom13)
Active Member
Joined: 1 year ago

ok update here: it seems the Plugin Post View Stats causes the conflict with php 8.0. but nevertheless please be sure and check the compatibility also with your plugin again, and if nessesary update this. many thanks ! 

1 Reply
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2610

Posted by: @atom13

ok update here: it seems the Plugin Post View Stats causes the conflict with php 8.0. but nevertheless please be sure and check the compatibility also with your plugin again, and if nessesary update this. many thanks ! 

wpForo 2 compatibility is 100% ok with PHP 8.0.x.

There is nothing to check that hasn't been allready checked 🙂