Notifications
Clear all

wpForo 1.x.x [Closed] Posting is a bit slow

6 Posts
3 Users
2 Reactions
642 Views
Posts: 371
Topic starter
(@danniee)
Honorable Member
Joined: 5 years ago

Hi,

I love the forum software, but it seems posting on the forum is a bit slow, at least for me. It takes 2-3 seconds before it has stopped loading and adds the post. I have googled and seen that others have experienced the same issue in the past.

Do you have any idea what could be causing something like this? Posting a comment with wpdiscuz, for example, is quite fast and I don't see this problem there.

  • Forum caching is ON
  • Forum is excluded in WP Rocket cache
  • I use Cloudflare
  • Forum has around 350 members but not a whole lot of posts
  • Browsing the forum is not particularly slow
  • I've researched and found your info on Innodb and myisam. I see I have a mix. Could this be the issue?

Many thanks

5 Replies
Sofy
Posts: 4421
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

@danniee,

Please read this FAQ: https://wpforo.com/community/faq/forum-is-slow/

dimalifragis
Posts: 2609
(@dimalifragis)
Famed Member
Joined: 4 years ago

@danniee after reading the above and tune accordingly, if your issues remain, you should find what slows down your site.

There are several tools for that, WP plugins, external online sites ...

Also you must be sure your site is not experiencing any errors (debug.log).

For me, it is not innodb or issam or things like that, it is 99% of the times slow hosting. Again, IF there are no errors or issues in Wordpress.

And reading your post, it would be hard to debug, with all those things enabled. Rocket cache, CloudFlare etc etc.

1 Reply
(@danniee)
Joined: 5 years ago

Honorable Member
Posts: 371

@dimalifragis thanks for the reply mate, appreciate it. I think what it comes down to ultimately is probably the host. Currently on shared hosting. Will move to either Kinsta or WP Engine. You have any experience with any of them?

dimalifragis
Posts: 2609
(@dimalifragis)
Famed Member
Joined: 4 years ago

No i have no experience with them. But again, find the real cause of your slow down. It is important not to chase ghosts that do not exist.

This can be only be done with a plan. Disable this and that, change this and that, enable this and that and see what is wrong.

A url of your site could help us more, if you can of cource.

1 Reply
(@danniee)
Joined: 5 years ago

Honorable Member
Posts: 371

@dimalifragis trust me, that is exactly what I have been doing the past 2 weeks. Disable plugins, tweak cache settings, tweak cloudflare, etc, etc. Tried everything. Different combinations. Asked around.

Disabling a slider plugin definitely speeds up the site. That is the only real culprit I have found. A few devs that have looked at my site suggest I change host.