Notifications
Clear all

[Solved] Private Forum Visible But Not Accessible?

22 Posts
3 Users
1 Likes
306 Views
Posts: 84
 eel
Topic starter
(@eel)
Estimable Member
Joined: 3 years ago

I want to make a private forum, which I know how to do. I've also read this:

https://wpforo.com/community/faq/wordpress-user-roles-wpforo-usergroups-and-forum-accesses/

The existing private forum on my site is not visible to anyone who is not a member of the private class. 

I want to make another private forum, but I want this one to show on list of forums but only be assessable to people who have been granted permission. Is this possible?

Thanks,

21 Replies
Chris
Posts: 2751
Admin
(@chris)
Support Team
Joined: 2 years ago

Hi @eel,

Create a New Access, Enable the below options for the New Forum Access, and use the new access in the needed forum.

  • Can view forum
  • Can enter forum
  • Can view topic

Users can enter the forum can see the topics, but cannot enter the topics.

9 Replies
 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84

@chris Thank you! I am going to do this now but I have another question. I also use the wpforo widget that displays recent forum comments. How can I exclude or block the display of the comments in the private forum?

Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2751

@eel,

Forum Access options are working on widgets as well. So there is nothing new for you, just work with accesses and set the forum permission by your needs.

 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84

@chris thank you.  The content is showing on the widget. I'm not sure what I'm missing here.  I set the access, permissions and the test fails. Screenshots follow.

 

 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84
 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2751

@eel,

Make sure that you are using Recent Posts widget.
NOT Recent Topics Widget, as in your Forum Access you give the permission to see topics.

 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84

@chris thanks! I see the distinction there. Problem is, people can see something tasty on sidebar widget; click it and find out they're blocked. It seems this will frustrate the user. Is there anyway to omit the private from from the widget(s), entirely?

Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2751

@eel,

You can use Filter by Forums option in widgets settings. Set the widget to show public forum content, not the private one.

 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84

@chris thank you. I see this option on both topics and posts widgets but I don't see how to select the forums to omit or include.

Posts: 84
 eel
Topic starter
(@eel)
Estimable Member
Joined: 3 years ago

One more question - sorry!  How can I exclude the private forum from being indexed by Google - or is this automatic?

Thanks.

7 Replies
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2751

@eel,

Navigate to wpForo > Settings > wpForo SEO and check Noindex forum page URLs field.

 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84

@chris thanks! I would like the other forums indexed so if the private forum is "colosseum", would this be the way?

https://www.elsaelsa.com/forum/colosseum/*

Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2751

@eel,

https://www.elsaelsa.com/forum/colosseum/

No need for *

 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84
 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

@eel,

The filter by forum doesn't work yet. Please don't use it. It'll be fixed in one of the upcoming versions.

As per the private forum displaying issue, you should set the following permissions to the forum accesses you use (wpForo > Accesses):

  • Yes | Can view forum
  • No  | Can enter forum

So, users will see forums, but they'll not be able to see the topics inside the forums.

 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84

@robert thank you!  You've all been a great help. All questions have been answered and all issues are resolved.

Posts: 84
 eel
Topic starter
(@eel)
Estimable Member
Joined: 3 years ago

Oh, shoot! One more question:

Can this be edited?

"Your user level does not have appropriate permission to view the content"

With instructions re: how to join?

Thanks!

2 Replies
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2751

@eel,

Navigate to wpForo > Phrases search that phrase and edit it.

 eel
(@eel)
Joined: 3 years ago

Estimable Member
Posts: 84

@chris perfect. thank you!