Notifications
Clear all

[Solved] Problem with link when updating to 2.0.2

4 Posts
3 Users
0 Reactions
482 Views
Posts: 2
Topic starter
(@lucaslopardo)
New Member
Joined: 2 years ago

Hello, my site is vintaradio.com
When I updated the version of WPforo the links to login, members, participant stopped working:
Example
https://vintaradio.com/sign-in/?redirect_to=https%3A%2F%2Fvintaradio.com%2Findex.php%2Fforo%2F
I can't find how to fix it, could you help me?

Topic Tags
3 Replies
1 Reply
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2612
Posted by: @lucaslopardo

Hello, my site is vintaradio.com
When I updated the version of WPforo the links to login, members, participant stopped working:
Example
https://vintaradio.com/sign-in/?redirect_to=https%3A%2F%2Fvintaradio.com%2Findex.php%2Fforo%2F
I can't find how to fix it, could you help me?

Go to your Wordpress Settings / PERMALINKS and remove the "index.php" part and leave just Post Name or whatever other you need.

The Index.php is wrong and confusing.

Robert
Posts: 10529
Admin
(@robert)
Support Team
Joined: 8 years ago

@lucaslopardo,

I think the problem comes from index.php prefix to all URLs in your website. For some reason all your page URLs have such prefix, for example:

https:// vintaradio.com/ index.php/ contacto/

Could you remove this unnecessary part from your website permalink structure?

Once you updated to 2.0, please go to wpForo > Settings > General Settings  admin page and click update options to refresh forum permalinks.

Also, make sure you have one forum page, I see many versions of forum base URL: community-3/, Foro/, etc...

Posts: 2
Topic starter
(@lucaslopardo)
New Member
Joined: 2 years ago

Thank you very much everyone, I have made the proposed corrections and now it works correctly